httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Strike" <stri...@pacbell.net>
Subject Re: [users@httpd] AddTypes in <Directory>
Date Fri, 16 May 2003 17:38:32 GMT
From: "Marko Leer" <marko@half2.nl>

> I'm running Apache 1.3.27 and I'm wondering why my configuration
> doesn't work if I add an addType within a <Directory> within a
> <Virtualhost> like this:
> 
> <VirtualHost 123.123.123.123>
> [some more stuff here]
>            <Directory /home/users/foo>
>            AddType application/x-httpd-php .php
>            AddType application/x-httpd-php .html
>            AddType application/x-httpd-php .dgif
>            AddType application/x-httpd-php .img
>            AddType application/x-httpd-php .htm
>            AddType application/x-httpd-php .php
>            </Directory>
> </Virtualhost>
> 

Make sure that you don't ahve an .htaccess file overriding your 
configurations it the directories this applies to.

Also, You only need one AddType directive per container.
(AddType application/x-http-php .php .hp3 .dgif .img .htm)
The dot is optional.


Cheers,
Tom S.
http://www.SleepyValley.net/me


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message