httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alasdair Lumsden" <apa...@alivewww.com>
Subject RE: [users@httpd] Stupid PHP Question
Date Thu, 22 May 2003 13:06:39 GMT
> I haven't been keeping up in the last year on PHP, so
> I was wondering if PHP will finally work properly
> under Apache 2.x.

My opinion (which has less than solid reasoning behind it!), is no.

It works "for the most part", but I've experienced some strange
behaviour which is so bizarre it's almost impossible to pinpoint. One
example is a PHP Sessions Problem I was having, where PHP 4.3 on Apache
2.x (Can't recall which - was quite a new edition) would loose the
session randomly, and fail to insert 'PHPSESSID=' on all the links when
a browser has cookies disabled.

I spent hours trying to fix it. Then I tried the script on PHP 4.3 on
Apache 1.3.27, and it worked perfectly with no flaws.

If you're going to be using it in a single installation then I'd imagine
it would "for the most part" be fine, but in a shared environment where
you will have many people using it, I'd say no.

But then this is an opinion, others may have a different experience.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message