httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vasile.Cure...@cgi.com
Subject Re: [users@httpd] Apache 2.0.45/mod_ssl "rv == APR_SUCCESS" startup error
Date Thu, 10 Apr 2003 15:43:12 GMT





Now I answer the question myself.

replacing the virtualhost default setting  in ssl.conf
<VirtualHost _default_:443>

#  General setup for the virtual host
DocumentRoot "/usr/local/apache2/htdocs"
..........
with the IP or the domain name the server is responding to
will just do it. vasile




                                                                                         
              
                      Vasile.Curelea@cg                                                  
              
                      i.com                    To:       users@httpd.apache.org          
              
                                               cc:                                       
              
                      04/09/03 02:02 PM        Subject:  [users@httpd] Apache 2.0.45/mod_ssl
"rv ==     
                      Please respond to         APR_SUCCESS" startup error               
              
                      users                                                              
              
                                                                                         
              








I get the following error on startssl!

# sh apachectl startssl
[Wed Apr 09 13:31:05 2003] [crit] [Wed Apr 09 13:31:05 2003] file vhost.c,
line 232, assertion "rv == APR_SUCCESS" failed
Abort - core dumped

I would appreciate any help on this! Thanks!

Compiled Apache on solaris 8 intel with the following options:

./configure --with-layout=Apache --prefix=/usr/local/apache2 \
--enable-mods-shared=most \
--with-ssl=/usr/local/ssl \
--enable-ssl=shared \
--enable-rewrite=shared

make, make install  with success
also installed OpenSSL engine
openssl-engine-0_9_6i
with the following options:

./config shared
make
make test
make install

created .key .csr and a .cert referenced them in ssl.conf
Please any help on this startup error is appreciated. vasile



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org





---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message