httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Foreman" <dfore...@stny.rr.com>
Subject [users@httpd] Cannot run CGI's
Date Thu, 17 Apr 2003 19:34:45 GMT
Hello again,
I'm still having trouble with trying to allow users to run CGI's (.exe's).
When any user (including myself on the same machine as the server) tries to
run a CGI program, the error log says:

 "(OS 5) Access is denied."

This is on a WInXP system in a domain (named WTSN). I have already applied
an Alias to translate the userid to append the domain, as required by XP,
and have set up the ScriptAlias to match the translated ID.

I also tried (unsuccessfully) to use variations on the following hint sent
me by Joseph Loegering:
<Files *.cgi>
SetHandler cgi-script
AddHandler .cgi .exe
</Files>

When I run the same program on a non-domain system (also WinXP), I get no
such error. In fact, I can move the CGI program to other locations on my
non-domain PC (as long as I change the cgi-bin and scriptalias statements in
httpd to match) with no problems. The directory and scriptalias setups on
both systems are identical (even having the same names, except the ID having
the ".wtsn" appended). The WinXP access privileges and "run as" are the same
on both systems.

I suspect it has to do with the userid ending in .WTSN. I've checked all the
FAQs I can find that appear related. I've searched the Apache site for "OS
5" and "access is denied", but they give no clue as to the cause. I think
I've done all the required homework and could use some help.

Does anyone have any idea why this may be happening? And how I can fix it.

regards,
D. J. Foreman, Ph. D.
website: http://WWW.CS.Binghamton.EDU/~foreman



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message