httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicholas Payne-Roberts" <nickpaynerobe...@hotmail.com>
Subject [users@httpd] Image display + javascript issue.
Date Fri, 25 Apr 2003 17:51:48 GMT
Thanks for the suggestions Sander.

I have tested the site from another browser (ie6, netscape 7.1 & Phoenix) 
and they all have the same output. So i then removed the <Alias... & 
<Directory... i had setup for my /js/ directory and instead created an 
acctual /js/ dir within my document root. This made no difference to the 
output either, so i then tested it via telnet as you suggested and hey 
presto! i have an error, "The server does not support the action requested 
by the browser." Trouble is i have no clue what i am missing from my server 
config so i shall post the output of apachectl -V & -l so you can see what i 
have installed.

///////////////////////
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/usr/local/apache2"
-D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
-D DEFAULT_PIDLOG="logs/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
///////////////////////
Compiled in modules:
  core.c
  mod_access.c
  mod_auth.c
  mod_include.c
  mod_log_config.c
  mod_env.c
  mod_setenvif.c
  prefork.c
  http_core.c
  mod_mime.c
  mod_status.c
  mod_autoindex.c
  mod_asis.c
  mod_cgi.c
  mod_negotiation.c
  mod_dir.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_so.c
//////////////////////

And also the ./configure i used:

./configure --enable-so --disable-dav

rather small i know :)

Just to re-iterate what i said before: i started out with 2.0.45/44/42/41 
with various configured builds, all of which ended up producing the same 
result; not outputting any images/css/html/js but DID (when compiled) output 
php pages with any images imbeded! So i stepped back and back in versions 
untill i reached 2.0.40 which outputted all but js.

Also, not sure if this has anything to do with whats happening here, but 
when my error_log is set to debug, my log fills with the following [info]:
(22)Invalid argument: core_output_filter: writing data to the network
(22)Invalid argument: core_output_filter: writing data to the network
(22)Invalid argument: core_output_filter: writing data to the network
(104)Connection reset by peer: core_output_filter: writing data to the 
network
(32)Broken pipe: core_output_filter: writing data to the network


And finaly, just to add that i have built this on the following 3 setups, 
all of which share the same linux kernel version(2.4.1-008stab035.29.swsoft 
#1): linux7.1p6 / linux7.1p12 / linux8.0

Would appreciate it if anyone could assist me with these(this) problem, as i 
would like to go back to 2.0.45 if at all possible.



>From: "Sander Holthaus - Orange XL" <info@orangexl.com>
>Reply-To: users@httpd.apache.org
>To: <users@httpd.apache.org>
>Subject: RE: [users@httpd] image display problem + javascript alias issue.
>Date: Fri, 25 Apr 2003 02:39:18 +0200
>
>Apache 2 and PHP are not fully compatible yet. For a
>production-envirorement, consider Apache 1.3.27 and PHP 4.
>
>Running 2.0.40 is a serious risk. You shouldn't, not just for yourself but
>for the Apache-community as a whole. Also, you problem could be a bug 
>that's
>fixed in a later version.
>
>To adress your problems. If some images are showing, and others aren't, are
>you sure that the problem lies with Apache? Have you tried different
>browsers, different clients? Are you using a proxy, firewall or such?
>Perhaps post you can post a part of your server log?
>Try to get a telnet connection up and running, and request some images. 
>Look
>at the headers and the content. If the problem lies with Apache, you should
>be able to spot it.
>
>Java and Javascript are two very different things. But anyhow, javascript
>files should always work out of the box (apache doesn't do anything with
>them). Do they have a .js extension? Is Apache outputting the proper
>MIME-type (again, use TELNET) and set in your html (<script
>type="text/javascript">)? Tried different browsers?
>
>Apache 2.0.4x should "work" with PHP 4 up. The problems you are describing
>suggest a configuration-problem. Perhaps you can post your server-config?
>
>Kind Regards,
>Sander Holthaus
>
>
>-----Original Message-----
>From: Nicholas Payne-Roberts [mailto:nickpayneroberts@hotmail.com]
>Sent: vrijdag 25 april 2003 2:08
>To: users@httpd.apache.org
>Subject: [users@httpd] image display problem + javascript alias issue.
>
>
>Does anybody know why certain images on my site won't display, even though
>images with the same settings next to them will? I have done  chmod 755 /
>chgrp & chown -R to all of /var/www/.
>I have also seen the images in their path from within a web-admin tool for
>my VE, so I know that they are not corrupt.
>
>2nd problem: I have setup an Alias for a javascript directory, but scripts
>arn't loading at all (used to load before I upgraded).
>
>Here are the details of what I have configured within my httpd.conf:
>
>Alias /js/ "/var/www/js/"
>
><Directory "/var/www/js">
>     AllowOverride None
>     Options All
>     Order allow,deny
>     Allow from all
></Directory>
>
>My error_log (set to warn) reports 200 of each .js that is requested, even
>though when you attempt to use any of the scripts, they won't run. Did i
>miss-compile my apache, missing a java-function??
>
>I am running Apache 2.0.40 & PHP-4.3.1, running on a VE which has
>RedHat-7.1p12.
>
>P.S. I would be running 2.0.45 but I found that no images, css, scripts or
>even htmls would output to the client except php, from build 2.0.41 and
>upwards.
>
>Thanks in advance to anyone who could help.
>
>_________________________________________________________________
>Stay in touch with absent friends - get MSN Messenger
>http://www.msn.co.uk/messenger
>
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info. To
>unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>


_________________________________________________________________
Surf together with new Shared Browsing 
http://join.msn.com/?page=features/browse&pgmarket=en-gb&XAPID=74&DI=1059


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message