httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clayton Cranor" <...@ntlalaska.com>
Subject [users@httpd] startup problem for apache 1.3.27
Date Tue, 15 Apr 2003 20:14:03 GMT

I have a strange problem...  here is an example:

[root@denali bin]# ./httpsdctl start
[Tue Apr  8 12:09:25 2003] [error] Access to file
/usr/local/apache_1.3.27/conf/httpsd.conf denied by server: not a regular
file
fopen: No such file or directory
httpsd: could not open document config file
/usr/local/apache_1.3.27/conf/httpsd.conf
./httpsdctl start: httpsd could not be started

This after compiling with the following ./config sequence:

SSL_BASE=../openssl-0.9.6g
EAPI_MM=../mm-1.1.3
CCFLAGS=-DEAPI

./configure \
"--with-layout=Apache" \
"--prefix=/usr/local/apache-1.3.27" \
"--activate-module=src/modules/auth_mysql/libauth_mysql.a" \
"--enable-module=all" \
"--enable-shared=max"

I cannot see where this is coming from or why.  Here is a list of directory:

[root@denali bin]# ls /usr/local/apache_1.3.27/conf
total 176
   1 drwxr-xr-x   2 root     root         1024 Apr  8 12:08 .
   1 drwxr-xr-x  12 root     root         1024 Apr  8 12:03 ..
   1 -rw-r--r--   1 root     root          351 Apr  8 12:04 access.conf
   1 -rw-r--r--   1 root     root          351 Apr  8 12:04
access.conf.default
  38 -rw-r--r--   1 root     root        37282 Apr  8 12:08 httpsd.conf
  38 -rw-r--r--   1 root     root        37282 Apr  8 12:04
httpsd.conf.default
  38 -rw-r--r--   1 root     root        37282 Apr  8 12:04 httpsd.conf~
  14 -rw-r--r--   1 root     root        12965 Apr  8 12:04 magic
  14 -rw-r--r--   1 root     root        12965 Apr  8 12:04 magic.default
  14 -rw-r--r--   1 root     root        12381 Apr  8 12:04 mime.types
  14 -rw-r--r--   1 root     root        12381 Apr  8 12:04
mime.types.default
   1 -rw-r--r--   1 root     root          360 Apr  8 12:04 srm.conf
   1 -rw-r--r--   1 root     root          360 Apr  8 12:04 srm.conf.default

The system is an Alpha XLT, running Linux, started as 5.2 for alpha, but
I've kept up with the kernel updates (mostly) and most of the running
software.

Anybody got any ideas? I'm stumped.

Clay Cranor
cranor at denalicomputing dot com




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message