httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Crawford <>
Subject [users@httpd] Basic Authentication with Apache 2.44 on Solaris 8 doesn't appear to work
Date Fri, 25 Apr 2003 23:30:05 GMT
My Directory section looks like this:

<Directory "/space/usr/jrun4/servers/default/cfusion/DLC/admin/">
AuthType Basic
AuthName "Restricted"
AuthUserFile /space/usr/jrun4/servers/default/passwd/passwords
Require user cfusion

However, when I go to the website in question, I'm not prompted for a 
username or password.

I've tried removing the quotes around the directory name, I've tried 
removing the trailing slash, I've tried putting quotes around the 
AuthUserFile name, I've tried recreating the passwords file several 
times.  I've quadruple-checked to make sure all of the directories and 
files that are referenced exist.  I have tried placing the <Directory> 
section in the main part of the httpd.conf file, and I've tried placing it 
in the virtual hosts section as well.  I'm stumped.

I have the feeling that I may be missing something.  I've searched and 
re-searched on the Apache website and in several other websites that I've 
bookmarked that have to do with Apache security.  I've looked through the 
rest of the httpd.conf file to make sure there are no other settings that 
could override the authentication here, and while I am no Apache guru I 
don't think I've missed anything... but I could be wrong.

Does anyone have any suggestions as to where else in httpd.conf I might 
want to look, or any additional directives I should put into my <Directory> 
setting?  I'm not sure if the placement of the Directory section in the 
httpd.conf file should matter at all (my understanding is that it doesn't), 
but if it does, where should I put it?

The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message