httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Luchjenbroers <A...@Luchjenbroers.com>
Subject [users@httpd] PHP 2.3.1 & Apache 2.0.45 - All scripts cause internal server errors
Date Thu, 10 Apr 2003 21:48:14 GMT
Apache produces an internal server error when attempting to run any PHP 
script no matter how simple, for example:

<?php
phpinfo()
?>

server error log turns up entries like this

> Premature end of script headers: install.php 

Did turn up this, but its no help to me on its own
http://httpd.apache.org/docs/misc/FAQ.html#premature-script-headers

All scripts run perfectly when invoked via the commandline version of php, 
using either the root or apache accounts on the server.

apachectl checkconfig returns syntax ok (1 error about not being able to 
find the computers FQDN, but that is all)

The following lines are in my httpd.conf file

LoadModule php4_module /usr/modules/libphp4.so 
AddType application/x-httpd-php .php

Any ideas as to where the problem lies?

-- 
"Microsoft is a cross between the Borg and the Ferengi. Unfortunately, they 
use Borg to do their marketing and Ferengi to do their programming." - Simon 
Slavin

Please avoid sending me Word or PowerPoint attachments.
See http://www.fsf.org/philosophy/no-word-attachments.html



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message