httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roberto Barbieri" <r.barbi...@carpinet.it>
Subject [users@httpd] Strange behaviour of user's pages
Date Thu, 03 Apr 2003 15:28:04 GMT
Hi,

i noticed a strange thing happening with users homepages.

When a user put files or directories on his /home/user/public_html dir
everithing, including indexing, works fine.
The strange thing happens when the user create a .htaccess file
inside a subdirectory, like:

/home/user/public_html/subdir/.htaccess

After creating this file, if i try to browse http://hostname/~user/
the directory "subdir" disappear while the others files and directories
are shown. Obviously if i remove the .htaccess files all works fine again
and the "subdir" shows itself again.

What the problem can be?

This is how the user's homepages are configured:

<Directory /home/*/public_html>
    AllowOverride FileInfo AuthConfig Limit
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    <Limit GET POST OPTIONS>
        Order allow,deny
        Allow from all
    </Limit>
    <LimitExcept GET POST OPTIONS>
        Order deny,allow
        Deny from all
    </LimitExcept>
</Directory>


Thanks in advance for any help!
Roberto

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message