httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Sheridan-Peters" <...@usp.org>
Subject [users@httpd] Need help - DirectoryIndex failure with SSL?
Date Thu, 20 Mar 2003 16:21:59 GMT
This happens with Apache 2.0.43 and 2.0.44 on a Sparc/Solaris 8 machine.

I'm trying to get an SSL-only site working that worked fine as a regular HTTP site.  The content
serves perfectly fine if you specify the complete URL to the content file, but fails due to
the implicit redirect/rewrite if you specify a directory - ie. DirectoryIndex takes over and
tries to dish up the index file for the directory.

Some examples:

https://site.usp.org/dir/ fails upon being rewritten/redirected to http://site.usp.org:443/dir/index.html

https://site.usp.org/dir/index.html succeeds.

I've tried with a browser and with cURL from the command line and the same thing happens.
 Here's the headers I get back when requesting https://site.usp.org/dir/.

HTTP/1.1 302 
Date: Thu, 20 Mar 2003 16:03:32 GMT
Server: Apache/2.0
Location: http://site.usp.org:443/dir/index.htm
Content-Type: text/html;charset=ISO-8859-1
Content-Language: en
Transfer-Encoding: chunked

I'm really crunched for time to get this going and I'm hoping someone can tell me what's up
with this.  Surely I can't be the only one to have run into this?

--
James Sheridan-Peters
USP



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message