httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From geb...@ameritech.net
Subject RE: [users@httpd] VirtualHost problem
Date Thu, 27 Mar 2003 10:55:53 GMT

Just to make sure I'm understanding correctly:

NameVirtualHost 192.168.0.10:443 (or 80)   Bad.

VirtualHost 192.168.0.10:443 (or 80)       Good

Yes?

tnx,
ken

At 18:39 (UTC-0500) on Wed, 26 Mar 2003 Jeff Cohen said:

= Both of you check that you don’t have VirtualHost 192.168.0.10:443 or 80
= and not NameVirtualHost 192.168.0.10:443 or 80 - No mixing IP/Name with
= ports.
= 
= All the best,
= Jeff Cohen
= 
= > -----Original Message-----
= > From: Bob Wise [mailto:bob@bobsplanet.com]
= > Sent: Wednesday, March 26, 2003 5:38 PM
= > To: users@httpd.apache.org
= > Subject: RE: [users@httpd] VirtualHost problem
= > 
= > 
= > I had exactly the same problem. I spent some time trying to figure
= > out what this meant... and couldn't come up with a good answer.
= > 
= > However, I did come up with a workaround... which was to use
= > the local IP address like:
= > 
= > NameVirtualHost 192.168.0.10
= > 
= > Note that I'm on the other side of a NAT server... what worked
= > was the local IP address, not the external IP address. This would
= > be troublesome if the IP address changed - so using the * would
= > be better.
= > 
= > In any case... it's a workaround and I'd like to hear the why
= > of it, too.
= > 
= > -Bob
= > 
= > -----Original Message-----
= > From: Håkan Molin [mailto:hakan@lulle.dyndns.org]
= > Sent: Wednesday, March 26, 2003 3:09 PM
= > To: users@httpd.apache.org
= > Subject: [users@httpd] VirtualHost problem
= > 
= > 
= > Hi!
= > 
= > I'm trying to set up namebased virtual hosts using the RedHat8.0 default
= > Apache2.0 installation.
= > 
= > Despite following the advise on the
= > http://httpd.apache.org/docs-2.0/vhosts/ web page, I keep getting the
= > following error message when (re)starting the httpd daemon:
= > 
= > "[error] VirtualHost _default_:443 -- mixing * ports and non-* ports
= > with a NameVirtualHost address is not supported, proceeding with
= > undefined results"
= > 
= > I can't figure out what might be wrong; as far as I can see I'm NOT
= > mixing "* ports" (<VirtualHost *>) and "non-* ports" (<VirtualHost
= > *:80>) statements in my conf file.
= > 
= > Anyone have a hint?
= > 
= > //Hakan
= > 
= > 
= > 
= > ---------------------------------------------------------------------
= > The official User-To-User support forum of the Apache HTTP Server Project.
= > See <URL:http://httpd.apache.org/userslist.html> for more info.
= > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
= >    "   from the digest: users-digest-unsubscribe@httpd.apache.org
= > For additional commands, e-mail: users-help@httpd.apache.org
= > 
= > 
= > ---------------------------------------------------------------------
= > The official User-To-User support forum of the Apache HTTP Server Project.
= > See <URL:http://httpd.apache.org/userslist.html> for more info.
= > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
= >    "   from the digest: users-digest-unsubscribe@httpd.apache.org
= > For additional commands, e-mail: users-help@httpd.apache.org
= 
= 
= ---------------------------------------------------------------------
= The official User-To-User support forum of the Apache HTTP Server Project.
= See <URL:http://httpd.apache.org/userslist.html> for more info.
= To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
=    "   from the digest: users-digest-unsubscribe@httpd.apache.org
= For additional commands, e-mail: users-help@httpd.apache.org
= 
= 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message