httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julian Grunnell" <jgrunn...@firstnet.net.uk>
Subject [users@httpd] Apache2 + mod_deflate error
Date Wed, 12 Mar 2003 12:08:58 GMT
Hi - wonder if someone could help me with above pls.

Platform - Debian Linux 2.2.17
Apache 2.0.44

Config.nice:
"./configure" \
"--prefix=/usr/local/apache2044" \
"--enable-mods-shared=all" \
"--enable-deflate" \

If I try to start apache with "mod_deflate" enabled in the httpd.conf
file I get the following error:

monkeyripper:/usr/local/apache2044/conf# ../bin/apachectl configtest
Syntax error on line 239 of /usr/local/apache2044/conf/httpd.conf:
Cannot load /usr/local/apache2044/modules/mod_deflate.so into server:
/usr/local/apache2044/modules/mod_deflate.so: undefined symbol: deflate

This is line 239:
	LoadModule deflate_module modules/mod_deflate.so

Commenting out "mod_deflate" + apache works just fine.

Someone said it was to do with "zlib" either not being installed or not
in the path - but they are and it still doesn't work.

Any help / advice would be greatly appreciated.

J.

Julian Grunnell
3rd Line Technical Support
E: jgrunnell@firstnet.net.uk
T: 0870 1278008 F: 0870 1278009
DDI: 0113 292 7739
http://www.firstnet.net.uk

Firstnet Services Ltd
Registered Office: Peregrine House, Gelderd Close, Leeds, LS12 6DS 
Registered in England no. 3152569

This email is subject to: http://www.firstnet.net.uk/disclaimer.html

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message