httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Culp" <dc...@mcleodhealth.org>
Subject Re: [users@httpd] Help w/ mod_perl installation.
Date Thu, 27 Mar 2003 03:51:05 GMT


Mike,
     Did you statically link them at compile time ?
     [mod_perl ]
          perl Makefile.PL Apache_SRC = ../apache_1.3.27/src  ...
          make
          make install

     [Apache ]
          ./configure --activate-module=src/modules/perl/libperl.a  ....
          make
          make install

     Once you start Apache - you should see in the log about mod_perl being
included.

     There's nothing else to do with httpd.conf except when you start using the
many
     features of mod_perl

     Hope this helps
David










Mike Diehl <mdiehl@dominion.dyndns.org> on 03/26/2003 10:39:59 PM

Please respond to users@httpd.apache.org; Please respond to
      mdiehl@dominion.dyndns.org
                                                                                
                                                                                
                                                                                


                                                              
                                                              
                                                              
 To:      users@httpd.apache.org                              
                                                              
 cc:      (bcc: David Culp/MRMC/McLeod_Health)                
                                                              
                                                              
                                                              
 Subject: [users@httpd] Help w/ mod_perl installation.        
                                                              







Hi all.

I just finished emerge'ing mod_perl and apache.  Now I'm trying to get
apache to load mod_perl when it starts.  What do I have to add to the
apache.conf file?

I need to know how to set the LoadModule and AddModule directives.  Actually,
I'd like to know why we have to seemingly identical directives.

Thanx in advance,
Mike Diehl.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org





---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message