httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Carleton <...@linux-info.net>
Subject Re: [users@httpd] digest authentication
Date Thu, 06 Mar 2003 15:15:36 GMT
On Thu, Mar 06, 2003 at 10:59:51AM +0100, Boyle Owen wrote:
> >-----Original Message-----
> >From: Sam Carleton [mailto:sam@linux-info.net]
> >Sent: Mittwoch, 5. März 2003 19:00
> >To: apache-users
> >Subject: [users@httpd] digest authentication
> >
> >
> >I am trying to setup digest authentication.  Presently I am using
> >basic authentication:
> 
> Support for digest is browser dependent. Are you sure your browser
> supports it? (read the caveats in the auth tutorial in the docs).

I thought I had read it, but I read over it again.  It looks like I
am fine.  I am using IE 6.0.2800.1106 and Mozilla 1.3b on Windows
2000 Server.  I had only been trying to use IE, Mozilla has given
different results...
 
> What does "the page does not load" mean? - 401?, 403?, 404?, timeout?
> what?

I am sorry, I should have included log into.  Here is what is going
on.  With IE 6, there is this entry in the access log, nothing in
the error log:

XXX.XXX.XXX.XXX - - [06/Mar/2003:10:02:54 -0500] "GET /scarleton/
HTTP/1.0" 401 474 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT
5.0; .NET CLR 1.0.3705)"
XXX.XXX.XXX.XXX - - [06/Mar/2003:10:02:54 -0500] "GET /scarleton/
HTTP/1.0" 401 474 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT
5.0; .NET CLR 1.0.3705)"

Looks to me like it is a 500.

But with Mozilla, it DOES prompt me for a username and password, but
then returns a 500:

---access_log---
XXX.XXX.XXX.XXX - - [06/Mar/2003:10:01:54 -0500] "GET /scarleton/
HTTP/1.0" 401 474 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.3b) Gecko/20030210"
XXX.XXX.XXX.XXX - user [06/Mar/2003:10:02:07 -0500] "GET /scarleton/
HTTP/1.0" 500 611 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.3b) Gecko/20030210"


---error_log---
[Thu Mar  6 10:02:07 2003] [crit] [client 209.95.240.214]
configuration error:  couldn't check user.  No user file?:
/scarleton/

The error log entry leads me to believe that apache cannot find the
user file or it cannot read the user file.  I have checked and
rechecked the path and permissions to the files.  I have also
pointed to both a file created with htpasswd and with htdigest, I
get the same result with both.

Sam

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message