httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Carleton <...@linux-info.net>
Subject [users@httpd] problems with mod_digest
Date Tue, 04 Mar 2003 17:11:39 GMT
folks,

I am trying to setup a directory to have digest authentication.
First I learned that I needed to have mod_digest compiled and
installed, which I didn't when initially.  I recomplied apache and
all seems to be working fine except that the digest authentication
still is not working.

Here is what I have:

Alias  /scarleton "/export/home/carleton/scarleton"

<Directory "/export/home/carleton/scarleton">
	AllowOverride None
    Options MultiViews Indexes SymLinksIfOwnerMatch Includes ExecCGI

	AuthName development
	AuthType digest
	AuthUserFile /data01/www/passwd/digest.users
	Require valid-user

    Order allow,deny
    Allow from 192.168.0.0/24 172.16.0.0/24

	Satisfy any
</Directory>

Without the authentication stuff, it works fine from the intranet.
There is nothing in the error file and this is what the access log
looks like:

BAD:
209.x.x.x - - [04/Mar/2003:11:57:49 -0500] "GET /scarleton HTTP/1.0" 401 474 "-" "Mozilla/4.0
(compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)"

GOOD:
192.168.0.131 - - [04/Mar/2003:12:09:37 -0500] "GET /scarleton/ HTTP/1.0" 200 11828 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210"

Any and all help will be appreciated!

Sam

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message