httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Austermuehle ...@hcsd.de>
Subject [users@httpd] httpd 2.0.44 reports Bus Error on Solaris 9
Date Mon, 03 Mar 2003 14:38:30 GMT
Hello,

I just compiled the Apache httpd 2.0.44 with GCC 3.2.2 on a Solaris 9
MU2 (SPARC) system with the lastet patch cluster installed. I configured
the httpd to use the worker processing module:

	CC=gcc CFLAGS="-m64 -O3" ./configure ... --with-mpm=worker ...

The httpd starts normal:

	[Mon Mar 03 15:27:16 2003] [info] Init: Initializing OpenSSL library
	[Mon Mar 03 15:27:16 2003] [info] Init: Seeding PRNG with 0 bytes of entropy
	[Mon Mar 03 15:27:16 2003] [info] Init: Generating temporary RSA private keys (512/1024 bits)
	[Mon Mar 03 15:27:19 2003] [info] Init: Generating temporary DH parameters (512/1024 bits)
	[Mon Mar 03 15:27:19 2003] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
	[Mon Mar 03 15:27:19 2003] [info] Init: Initializing (virtual) servers for SSL
	[Mon Mar 03 15:27:19 2003] [info] Server: Apache/2.0.44, Interface: mod_ssl/2.0.44, Library:
OpenSSL/0.9.6i
	[Mon Mar 03 15:27:19 2003] [info] Init: Initializing OpenSSL library
	[Mon Mar 03 15:27:19 2003] [info] Init: Seeding PRNG with 0 bytes of entropy
	[Mon Mar 03 15:27:19 2003] [info] Init: Generating temporary RSA private keys (512/1024 bits)
	[Mon Mar 03 15:27:21 2003] [info] Init: Generating temporary DH parameters (512/1024 bits)
	[Mon Mar 03 15:27:21 2003] [info] Init: Initializing (virtual) servers for SSL
	[Mon Mar 03 15:27:21 2003] [info] Server: Apache/2.0.44, Interface: mod_ssl/2.0.44, Library:
OpenSSL/0.9.6i
	[Mon Mar 03 15:27:21 2003] [notice] Apache/2.0.44 (Unix) mod_ssl/2.0.44 OpenSSL/0.9.6i DAV/2
configured -- resuming normal operations
	[Mon Mar 03 15:27:21 2003] [info] Server built: Mar  3 2003 15:14:00
	[Mon Mar 03 15:27:21 2003] [debug] worker.c(1736): AcceptMutex: pthread (default: pthread)

Requesting the test pages installed in htdocs works good but when I
request the manual which includes a redirection I don't get an answer
but have the following message in the error_log:

	[Mon Mar 03 15:28:03 2003] [notice] child pid 14960 exit signal Bus error (10)

What's going on here?

Kind regards,

Stephan

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message