httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nigel Gilbert <n.gilb...@soc.surrey.ac.uk>
Subject [users@httpd] help with configure needed
Date Tue, 04 Feb 2003 22:54:41 GMT
I am upgrading to Apache 1.3.27 on a Solaris 7 box.

My httpd.conf file works fine on the old (1.3.20) version.  When I use 
the same conf file with the new version, I get the error:

Syntax error on line 82 of /opt/apache/conf/httpd.conf:
Invalid command 'TransferLog', perhaps mis-spelled or defined by a 
module not included in the server configuration

I used this ./configure command to build 1.3.27:

./configure \
  --prefix=/opt/apache \
  --enable-module=most \
  --enable-module=log_referer \
  --enable-module=log_agent \
  --enable-module=rewrite \
  --enable-shared=max

On my previous version, command httpd -l generated a long list of 
modules (including mod_log_config.c, which is the one that supports the 
TransferLog command).  With the new version, using httpd -l gives only:

Compiled-in modules:
   http_core.c
   mod_so.c
suexec: disabled; invalid wrapper /opt/apache.new/bin/suexec

What am I doing wrong in my configure?

Thanks for your help!

Nigel


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message