httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Astrid Hendra" <Ast...@sigel.co.nz>
Subject RE: [users@httpd] .htaccess + htpasswd NOT working
Date Wed, 26 Feb 2003 01:38:45 GMT
Hi there,

I have the same problem as Jason.  I've followed the information provided in the Apache Httpd
Documentation and also had some assistance from people on two irc channels and they ended
up referring me to this email list.
This is my VHost entry.  I've added the .htaccess into the httpd.conf as a directory.

<Directory /var/www/strudel>
 AuthName "Strudel Access"
 AuthType Basic
 AuthUserFile /var/www/strudel/.htpasswd
 AllowOverride All
 Require User strudel
</Directory>

<VirtualHost 210.54.31.225:80>
DocumentRoot /var/www/strudel
ServerName www.strudelsoftware.com
ErrorLog /var/log/apache/strudel-error.log
CustomLog /var/log/apache/strudel-access.log common
</VirtualHost>

I've set up the .htpasswd file permissions to the Apache Documentation.
The .htpasswd file has been put into the document root to rule out the possibility that the
apache user can't get to the directory it was formerly in.
When authentication is #'ed out in the httpd.conf I can access the website fine so the apache
user can acces the directory structure.

My error.log shows this when I try to enter in a login/password.

[Wed Feb 26 14:23:04 2003] [error] user strudel not found: /wedding/friends/
[Wed Feb 26 14:23:06 2003] [error] user strudel not found: /wedding/friends/

My access.log shows this at the same time.

10.20.1.13 - strudel [26/Feb/2003:14:23:04 +1300] "GET /wedding/friends/ HTTP/1.1" 401 489
10.20.1.13 - strudel [26/Feb/2003:14:23:06 +1300] "GET /wedding/friends/ HTTP/1.1" 401 489

The apache server reports this as being it's "vital information": Apache/1.3.27 (Unix) Debian
GNU/Linux mod_ssl/2.8.9 OpenSSL/0.9.6g PHP/4.2.3 configured

I've spent several days trying to get this work and doing research with no joy at all and
I would love some assistance :)
If I can offer anymore information to help solve the problem, please let me know.

Thank you very much,

Astrid Hendra.


-----Original Message-----
From: Jason S [mailto:jasonsmith@knology.net]
Sent: Tuesday, 25 February 2003 09:36
To: users@httpd.apache.org
Subject: Re: [users@httpd] .htaccess + htpasswd NOT working


> Hello Jason:
>
> Thanks!
>
> My Apache Information is:
> User nobody
> Group nobody
>
> My password file user/group is also same as above. But still getting
prompt
> infinite times.
>
> But in Apache document it was mentioned to change the characteristics to
> foll:
> chown root.nogroup /usr/local/apache/passwd/passwords
> chmod 640 /usr/local/apache/passwd/passwords
>
> Any other hints...?
>
>
> >From: "Jason S" <jasonsmith@knology.net>
> >Reply-To: users@httpd.apache.org
> >To: <users@httpd.apache.org>
> >Subject: Re: [users@httpd] Re: .htaccess + htpasswd NOT working
> >Date: Mon, 24 Feb 2003 15:05:29 -0500
> >
> > > Hi Joshua:
> > >
> > > I changed to "AllowOverride All"
> > > and now it shows the Prompt....but even after entering proper
> > > Username/Password...it keeps on prompting it infinite times.
> > >
> > > Any other suggestions?
> > >
> > > THANKS again!
> > >

> >Does your apache user own the /usr/local/apache/passwd/passwords file?

Do your apache error logs show failed authentications and reasons?

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message