httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trevor Hurst <t...@sgi.com>
Subject [users@httpd] httpd-2.0.44 with auth-ldap & apr-util
Date Wed, 26 Feb 2003 00:19:01 GMT

Hello,


I have successfully built Apache 2.0.44 from source with 
SSL support, etc, etc. The problem is that I need to have
LDAP authentication support for a project I am working on.

So... I have made several attempts at getting the same source
built with auth-ldap. System is running IRIX 6.5.19 with all 
of the tools such as autoconf, gnu make, gcc, libtools, etc...


I've built and installed apr and apr-util successfully. My only 
issue appears to be with the way configure wants to use apu-config (?)

Here's the configure options I'm using and the sed errors that follow
at the near end of the configure process:

./configure --enable-auth-ldap --with-apr= /usr/local/apr
--with-apr-util=/usr/local/apr --enable-mime-magic --enable-ssl \
--enable-static-rotatelogs --enable-so
--with-ssl=/usr/freeware/lib/openssl

creating Makefile
creating modules/Makefile
creating srclib/Makefile
creating os/beos/Makefile
creating os/os2/Makefile
creating os/Makefile
creating os/unix/Makefile
creating server/Makefile
creating support/Makefile
creating srclib/pcre/Makefile
creating test/Makefile
config.status: creating docs/conf/httpd-std.conf
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating include/ap_config_layout.h
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating support/apxs
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating support/apachectl
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating support/dbmmanage
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating support/envvars-std
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating support/log_server_status
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating support/logresolve.pl
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating support/phf_abuse_log.cgi
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating support/split-logfile
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating build/rules.mk
sed: command garbled: s,@APU_BINDIR@,Usage: apu-config [OPTION]
config.status: creating include/ap_config_auto.h
config.status: include/ap_config_auto.h is unchanged
config.status: executing default commands


Thanks for any insight you might bring, I've also tried pointing
configure
to my build trees for both apr and apr-util with the same results. 

-- Trev

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message