httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cal Henderson <...@iamcal.com>
Subject [users@httpd] problem with apachectl (apache 2, OSX)
Date Fri, 28 Feb 2003 11:35:31 GMT
hi,

i've compiled apache 2.0.44 on OSX with the following config:

./configure --enable-mods-shared=all /
  --with-berkeley-db=/usr/local/BerkelyDB.4.1 /
  --prefix=/usr/local/apache2

the compile goes find as does the install. then when i run
apachectl, i get:

---------------
dyld: /usr/local/apache2/bin/httpd version mismatch for library:
/usr/local/apache2/lib/libexpat.0.dylib (compatibility version
of user: 5.0.0 greater than library's version: 2.0.0)

../bin/apachectl: line 87: 8857 Trace/BPT trap    $HTTPD -k $ARGV
---------------

...but when i run httpd directly it starts fine with no errors.

i guessed the error indicates something wrong with expat, so i
recompiled a fresh expat (1.95.5 - 1.95.6 wont compile on OSX)
and the reconf'ed and recompiled apache, but i still get the same
error from apachectl.

any ideas?


thanks,

--cal



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message