httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Ho <ericy...@yahoo.com>
Subject [users@httpd] mod_rewrite (with P flag) problem with mod_ssl (in Apache 2.0) ??
Date Tue, 04 Feb 2003 01:51:33 GMT
Hi,I've the following mod_rewrite rule (in Apache
2.0)that tries to redirect ssl traffic.

The strange thing is that the mod_rewrite rules
worked.
The rule got triggered and the proxy module also got
triggered (due to the P flag).  And the remote SSL
server also got contacted (I can see the remote
server's cert in my logfile).  But then, the remote
server abruptly terminated the connection for no
reason....

Is there anything that I have done wrong (below) or I
have missed something...

Thanks much.
;-e).

=====================================
RewriteMap  alphas  txt:/maps/alphas.https

RewriteCond %{THE_REQUEST} ^(CONNECT\ )([^/\ ]+)(.*)$
RewriteRule ^(.*)$  https://${alphas:%2}$1  [P,L]

========================================

My SSL directives are:
==========================
SSLProxyEngine on
SSLProxyCipherSuite
kEDH:kRSA:kDHr:kDHd:aRSA:aDSS:aDH:aNULL:DES:3DES:RC4:IDEA:SHA:MD5:SHA1:+TLSvv1:+SSLv3:+SSLv2:+ADH

SSLVerifyClient none
SSLProxyVerify none
==========================



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message