httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joonas Makkonen <joonas.makko...@infosto.fi>
Subject RE: [users@httpd] Apache 1.3.26/Debian 3.0 Process spawn runaway
Date Wed, 19 Feb 2003 03:56:01 GMT
Hi,

We're having the exact same problem with Debian Apache 1.3.26-0woody running
with mod_jk as a frontend for tomcat servers.

I ran strace on the wild processes and here's the output:
send(12, "\0224\0\0", 4, 0)             = 4
recv(12, "AB\0\3", 4, 0)                = 4
recv(12, "\6\37\372", 3, 0)             = 3
send(12, "\0224\0\0", 4, 0)             = 4
recv(12, "AB\0\3", 4, 0)                = 4
recv(12, "\6\37\372", 3, 0)             = 3
send(12, "\0224\0\0", 4, 0)             = 4
recv(12, "AB\0\3", 4, 0)                = 4
recv(12, "\6\37\372", 3, 0)             = 3
send(12, "\0224\0\0", 4, 0)             = 4

in an endless loop. The output is always the same for every process gone loopy.

Any ideas? Has anyone experienced this problem with any other linux distro?

   -jm


> -----Original Message-----
> From: Morgan Collett [mailto:mcollett@verisign.com]
> Sent: Freitag, 31. Januar 2003 15:31
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] Apache 1.3.26/Debian 3.0 Process spawn
> runaway
> 
> 
> Hiya,
> 
> Load average hits about 200.
> The site runs Python - CGI and hits a MySQL 3.23 server on another box.
> This site sits in a data center with 3 DS3s, so plenty of bandwidth.
> 
> It runs fine most of the time, with load average less than 2. 
> All of a sudden 
> the load goes exponential and almost locks up the box completely.
> 
> Morgan
> 
> On Friday 31 January 2003 16:16, Boyle Owen wrote:
> > - What is the load average when it locks up? (use top to find out).
> > - Do you have a lot of CGI operations, DB operations etc.? Anything
> > which is CPU hungry.
> > - From the logs, what is your hit-rate? Output data rate?
> > - What is your bandwidth to the Web? (If you are serving data faster
> > than your pipe can drain it...)
> > 
> > Rgds,
> > 
> > Owen Boyle
> > 
> > > -----Original Message-----
> > 
> > From: Morgan Collett [mailto:mcollett@verisign.com]
> > 
> > > Sent: Freitag, 31. Januar 2003 14:50
> > > To: users@httpd.apache.org
> > > Subject: [users@httpd] Apache 1.3.26/Debian 3.0 Process 
> spawn runaway
> > > 
> > > 
> > > Hiya
> > > 
> > > We're running Debian 3.0 with Apache 1.3.26 (the stock deb package)
> > > and are encountering the following problem:
> > > 
> > > Twice a week or so, the site stops responding. We ssh in to find the
> > > load on the box very high (as much as 200!) with a ton of apache
> > > processes (200-300). Restarting apache fixes this problem
> > > immediately.
> > > 
> > > Unfortunately it is a production server, so we can't keep it in this
> > > condition for detailed troubleshooting... and we can't
> > > reproduce the problem
> > > on another system.
> > > 
> > > I've searched MARC and googled for various things like "apache
> > > process load"
> > > but have not found anything remotely relevant. What can you 
> suggest to
> > > troubleshoot this probem?
> > > 
> > > The following apache modules are installed - all stock Debian stuff:
> > > 
> > > LoadModule env_module /usr/lib/apache/1.3/mod_env.so
> > > LoadModule config_log_module /usr/lib/apache/1.3/mod_log_config.so
> > > LoadModule rewrite_module /usr/lib/apache/1.3/mod_rewrite.so
> > > LoadModule mime_module /usr/lib/apache/1.3/mod_mime.so
> > > LoadModule negotiation_module /usr/lib/apache/1.3/mod_negotiation.so
> > > LoadModule includes_module /usr/lib/apache/1.3/mod_include.so
> > > LoadModule autoindex_module /usr/lib/apache/1.3/mod_autoindex.so
> > > LoadModule dir_module /usr/lib/apache/1.3/mod_dir.so
> > > LoadModule cgi_module /usr/lib/apache/1.3/mod_cgi.so
> > > LoadModule alias_module /usr/lib/apache/1.3/mod_alias.so
> > > LoadModule access_module /usr/lib/apache/1.3/mod_access.so
> > > LoadModule auth_module /usr/lib/apache/1.3/mod_auth.so
> > > LoadModule auth_mysql_module /usr/lib/apache/1.3/mod_auth_mysql.so
> > > LoadModule expires_module /usr/lib/apache/1.3/mod_expires.so
> > > LoadModule setenvif_module /usr/lib/apache/1.3/mod_setenvif.so
> > > LoadModule ssl_module /usr/lib/apache/1.3/mod_ssl.so
> > > 
> > > The following other config parameters may be of interest:
> > > Timeout 300
> > > MinSpareServers 15
> > > MaxSpareServers 35
> > > StartServers 30
> > > MaxClients 300
> > > MaxRequestsPerChild 50
> > > KeepAlive On
> > > MaxKeepAliveRequests 100
> > > KeepAliveTimeout 15
> > > 
> > > The hardware:
> > > Dell PowerEdge 6650 / 4 GB RAM / 4 P4 Xeon CPUs
> > > 
> > > Linux kernel:
> > > 2.4.18
> > > 
> > > Thanks!
> > > 
> > > Morgan
> > > 
> > > 
> > 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message