httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Tamisiea <tamis...@jilau1.Colorado.EDU>
Subject [users@httpd] proxy server slow for certain sites
Date Fri, 24 Jan 2003 17:17:49 GMT
I recently installed apache-2.0.43 on a Tru64 v5.1 system.  While testing
the proxy server function, I found that some sites (cnn.com, for example)
stall in the middle of loading, causing the page to take over a minute
to load.  Because a google search didn't find many recent complaints of
hanging, stalling, or slowness with the proxy server, I assume that I
must have something wrong with my setup.   Below I have included the
relevant section from the httpd.conf file.  I also tried the default
setup in httpd.conf, using port 80 and only allowing access from a subnet,
with the same results.

<VirtualHost ###.###.###.###:3128>
ProxyRequests On
<Proxy *>
    Satisfy Any
    Order deny,allow
    Deny from all
    AuthType Basic
    AuthUserFile /usr/local/httpd/conf/users
    require valid-user
#    SetEnv force-proxy-request-1.0 1
#    SetEnv proxy-nokeepalive 1
</Proxy>
ProxyVia Off
HostnameLookups Off
ErrorLog logs/proxy_error_log
</VirtualHost>

The commented lines, lifted from the mod_proxy documentation, did not improve
the problem.  Apache reports no errors during the hangs and below is a sample
of the debug output during one of the hangs.

[Thu Jan 23 17:44:59 2003] [debug] proxy_http.c(109): proxy: HTTP: canonicalising URL //toolbar.aol.com/dashboard.twhat?dom=cnn
[Thu Jan 23 17:44:59 2003] [debug] mod_proxy.c(461): Trying to run scheme_handler
[Thu Jan 23 17:44:59 2003] [debug] proxy_http.c(1061): proxy: HTTP: serving URL http://toolbar.aol.com/dashboard.twhat?dom=cnn
[Thu Jan 23 17:44:59 2003] [debug] proxy_http.c(221): proxy: HTTP connecting http://toolbar.aol.com/dashboard.twhat?dom=cnn
to toolbar.aol.com:80
[Thu Jan 23 17:46:20 2003] [debug] proxy_util.c(1167): proxy: HTTP: fam 2 socket created to
connect to toolbar.aol.com
[Thu Jan 23 17:46:20 2003] [debug] proxy_http.c(370): proxy: socket is connected
[Thu Jan 23 17:46:20 2003] [debug] proxy_http.c(404): proxy: connection complete to 64.12.147.57:80
(toolbar.aol.com)

Does any have any suggestions of things that I can try in order to improve
performance, or other documentation I could read?

Thanks,
Mark

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message