httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felipe.Marcel...@sippican.com
Subject [users@httpd] Installing Apache 2.0.43 on Linux 7.3
Date Thu, 09 Jan 2003 15:33:10 GMT
I give up.
I've been trying to get PHP installed as a module with
Apache 2.0.43.  I want to install it on my laptop
strickly for development purposes.  Here's what I'm
doing:

The actors:
RedHat 7.3
PHP-4.3.0
Apache-2.0.43

The Stage:
HP OmniBook XE3
800MHz and some other stuff.

The scenario:
I install apache as follows:
./configure --prefix=/usr/local/httpd-2.0.43
--enable-so

make

make install

Now everything seems like it works, but the last
couple of statements look like they don't work.  I get
a Failure 1 on Initialize Recursive and the process
before that (but after installing the help files)

I go ahead and attempt to install php-4.3.0 anyway as
follows:
./configure
--with-apxs2=/usr/local/httpd-2.0.43/bin/apxs
--with-mysql --prefix=/usr/local/php-4.3.0

And I get an error that states that it can't verify
Apache 2 because of one of the following:
1) Perl not installed
2) Apache not compiled with --enable-so
3) Can't find apxs

Then it prints out the output of apxs (which is just
the usage menu)

Now because it prints out the usage menu it can't be
reason 1 or 3, so I'm guessing reason 2.  But I don't
know what the apache errors mean.

I'm using PHP4.3.0 because of the info on
http://dan.drydog.com/apache2php.html
but I still can't install it.

I'm sorry I can't be more specific on the error codes
from Apahce, I don't have the laptop with me
currently, but can anyone shed some light on the
situation?

Thanks in advance,
Phil




Mime
View raw message