httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarrod Harch <jarrodha...@idt-world.com>
Subject [users@httpd] ldap modules for Apache 2.0.44 on Win32 causing a crash
Date Fri, 31 Jan 2003 02:07:53 GMT
I posted this a little while ago on comp.infosystems.www.servers.ms-windows
, but just realised this may be a better place to ask.

I've been trying to get util_ldap and mod_auth_ldap working on Windows (2000
or XP).

I compiled Apache from sources and separately compiled and installed the
ldap modules according to the README.ldap file.

Apache builds fine and seems happy with my configuration.  However after I
attempt to access a resource protected by mod_auth_ldap, Apache crashes
while referencing wldap32.dll.  I have this file in my C:\Windows\System32
directory and have also tried copying it to Apache\modules.

My error.log show this:

[Fri Jan 31 10:01:10 2003] [debug]
C:\httpd-2.0.44\modules\experimental\mod_auth_ldap.c(676): [1212] auth_ldap
url parse: attrib: cn
[Fri Jan 31 10:01:11 2003] [debug]
C:\httpd-2.0.44\modules\experimental\mod_auth_ldap.c(678): [1212] auth_ldap
url parse: scope: base
[Fri Jan 31 10:01:11 2003] [debug]
C:\httpd-2.0.44\modules\experimental\mod_auth_ldap.c(683): [1212] auth_ldap
url parse: filter: (null)
[Fri Jan 31 10:01:11 2003] [debug]
C:\httpd-2.0.44\modules\experimental\mod_auth_ldap.c(750): [1212] auth_ldap
parse url: not requesting secure LDAP
[Fri Jan 31 10:01:11 2003] [notice] Child 1212: Child process is running
[Fri Jan 31 10:01:11 2003] [debug]
C:\httpd-2.0.44\modules\experimental\util_ldap.c(1066): (OS 3)The system
cannot find the path specified.  : [1212] ldap cache init: The system cannot
find the path specified.
[Fri Jan 31 10:01:11 2003] [debug]
C:\httpd-2.0.44\server\mpm\winnt\mpm_winnt.c(426): Child 1212: Retrieved our
scoreboard from the parent.
[Fri Jan 31 10:01:11 2003] [info] Parent: Duplicating socket 188 and sending
it to child process 1212
[Fri Jan 31 10:01:11 2003] [debug]
C:\httpd-2.0.44\server\mpm\winnt\mpm_winnt.c(623): Parent: Sent 1 listeners
to child 1212
[Fri Jan 31 10:01:11 2003] [debug]
C:\httpd-2.0.44\server\mpm\winnt\mpm_winnt.c(582): Child 1212: retrieved 1
listeners from parent

which to me looks like the server restarted itself?  The access.log file
shows only a 401 error for the request.

I'm guessing I made a mistake during compilation of the modules.  Step 2 in
README.ldap is a little cryptic ("the netscape/iplanet ldap libraries are
installed in srclib\ldap") - I didn't see these, but it compiled fine
without them so I assumed it would just be using the native Windows
functionality.  Has anyone else done this, does anyone see what the problem
might be?

Cheers
Jarrod


RECIPIENTS ARE REMINDED THAT THIS E-MAIL MESSAGE 
IS STRICTLY CONFIDENTIAL AND INTENDED ONLY FOR USE 
BY THE ADDRESSEE UNLESS OTHERWISE INDICATED. 

Investment Data Technologies Pty Ltd advise that they: 
- accept no liability for any abusive, defamatory, obscene, illegal, or 
offensive material contained in this e-mail message 
- do not monitor the content of any e-mail messages sent from 
Investment Data Technologies 
- do not authorise or condone the sending of abusive, defamatory, 
obscene, illegal, or offensive material by their employees and contractors 
- cannot guarantee that this e-mail message is secure and will not be 
intercepted by a third party. 



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message