httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j...@freedom.com
Subject [users@httpd] Reverse proxy issue
Date Tue, 07 Jan 2003 19:18:45 GMT
Hi,

I have an Apache server running as a reverse proxy for an intranet.  It had 
been set up incorrectly, and had "ProxyRequests On" so it was also being 
used as a forward proxy by the world.  With that now turned off, it can't 
be used as a forward proxy anymore.  But when testing, when I set my 
browser to use the server as a proxy, it fails (as it should) but it makes 
about 20 requests before it errors.  What it does, for example, is if I 
tell it that it is my proxy, and then try to go to yahoo.com, for instance, 
it first makes the request, then appends the proxy's domain name to the 
url, and keeps appending about 20 times, so when it's done, you end up with 
something like this in the browser:

yahoo.com.mydomain.com.mydomain.com.mydomain.com.mydomain.com.mydomain.com.m 
ydomain.com.mydomain.com.mydomain.com.mydomain.com.mydomain.com.mydomain.com 
.mydomain.com.mydomain.com.mydomain.com.mydomain.com.mydomain.com

So there is a loop going on somehow, which stops after about 20 
times.  It's Apache 2.0 on Win2k.  Thanks for any help.

-- John

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message