httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darryl Cook <...@cs.appstate.edu>
Subject Re: [users@httpd] Directory Listings
Date Fri, 17 Jan 2003 19:20:56 GMT
welll...... I changed it to the following:

<Directory />
    Options FollowSymLinks Includes Indexes
    AllowOverride All
    XBitHack on
 </Directory>

 <Directory /usr/local/etc/httpd/htdocs/u/cs/khj>
  Options -Indexes
 </Directory>

and it still doesnt work.....I did restart the server as well.  If I 
take Indexes out of the Directory / section then it doesnt allow them to 
view directory listings.  There is a symbolic link in the htdocs 
directory but Ive tried it using every possible combination with the 
same results.   I dont see any other Directory commands in the 
httpd.conf file except these two and no Location commands.

dont really see anything wrong at this point....

htdocs directory looks like this:
directory          u
link                   khj   ./cs/khj
directory           cs

darryl
Joshua Slive wrote:

>On Thu, 16 Jan 2003, Darryl Cook wrote:
>  
>
>><Directory />
>>    Options FollowSymLinks
>>    AllowOverride All
>>    Options +Includes +Indexes
>>    XBitHack on
>> </Directory>
>>
>> <Directory /usr/local/etc/httpd/htdocs/u/cs/khj>
>>  Options FollowSymLinks
>>  AllowOverride All
>>  Options +Includes -Indexes
>>  XBitHack on
>> </Directory>
>>    
>>
>
>Start by reading the docs for Options, with special attention to the
>effect of "+" and "-" options.  What you have makes no sense.
>http://httpd.apache.org/docs-2.0/mod/core.html#options
>
>Probably what you want is
>
><Directory />
>Options FollowSymLinks Includes Indexes
></Directory>
>
><Directory  /usr/local/etc/httpd/htdocs/u/cs/khj>
>Options -Indexes
></Directory>
>
>But that doesn't appear to be the main problem.  So, some other things to
>check:
>
>1. Are you ABSOLUTELY SURE that you are pointing to the right directory,
>and there are no symlinks or other funky things going on?
>
>2. Are you sure you don't have any <Location> sections or later
><Directory> sections overriding this configuration with another Options
>directive?
>
>3. Have you restarted the server after making changes?
>
>Joshua.
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>
>  
>



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message