httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Archie MacDonald (rsh)" <arc...@met.ed.ac.uk>
Subject [users@httpd] No access from external hosts specified in httpd.conf
Date Wed, 08 Jan 2003 10:32:40 GMT
Hi Apache Gurus

I have installed apache 1.3.27 on solaris 5.8  with php 4.2.3 as module
of apache.
Apache starts up okay and I can serve pages in my DocumentRoot and see
them in
my browser (Netscape). I can do this on other machines on my
departmental network
without any problem.

My problem is that I have changed the configure file to allow some
access from
some nasa jpl  machines but when I try to access the server from them it
fails with the
following message:-

" A network error occurred: unable to connect server (TCP Error: no
route to host)"

I have looked at the documentation,  also in
comp.infosystems.www.servers.unix
via google and at the apache.org website but have not been able to solve
this.

In the apache configure file I have tried (in <Directory> directive )
Allow from all
but still cannot access the server from the jpl.nasa.gov network.

I have tried using BindAddress *  and also :  Listen "my ip address
here":80
with and without the port no (80) specified in listen and none has
worked for
external access. I currently have Listen specified. I also have the Port
80 specified
as the port to listen to.

I used netstat -an | grep ".80 "  to find out if in fact it was
listening and it seemed to be
and I got ( server ip address removed):-

"my server ip address here".80         *.*                0      0
24576      0 LISTEN



As I mentioned , in the  server conf file I have used  the allow from
options to
specify specific networks to allow. (See below). I have even tried
specifying
specific computers but with no luck.


The following  has been extracted from my .config file:-

--------------------------------
[lots snipped ..]

<Directory "my document root here">
    Options Indexes FollowSymLinks MultiViews +Includes
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from met.ed.ac.uk
    Allow from jpl.nasa.gov
    Allow from 137.79.7
</Directory>

[ more sniped here ...]

<Directory /eosmls/local/apache/htdocs>
  AllowOverride none
  Options Indexes FollowSymLinks +Includes
  order deny,allow
  deny from all
  allow from ed.ac.uk 129.215.133 jpl.nasa.gov  137.79.7
</Directory>

[ lots more snipped ...]
--------------------------------

If I change the allow from ed.ac.uk 129.215.133 jpl.nasa.gov  137.79.7
to be separate allow from lines the error message from netscape changes
to :-

    "There was no response, the server may be down or not responding"


I looked in the log files (error,custom) but found nothing useful. No
error appears
when the external host is unable to connect. I changed the LogLevel  to
debug but
still nothing useful... :-(


Does anyone have any Ideas or suggestions of further things to look at
or
investigate.  I am a novice/newbie  with apache so I hope you can bear
with me.

Thanks in advance.

Regards, Archie


--
---------------------------------------------------------------------------
 Archie MacDonald                    Email: archie@met.ed.ac.uk
 EOS MLS Research Associate          Phone: +44 131 650 5096
 Institute for Meteorology           WWW  : http://www.met.ed.ac.uk/~archie/
 School of Earth, Environmental and Geographical Sciences
---------------------------------------------------------------------------




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message