httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laurent Blume <laurent.bl...@infores.com>
Subject [users@httpd] Apache 2.0.43 not logging IP addresses HP-UX 64 bits
Date Tue, 07 Jan 2003 12:38:53 GMT
Hello,

I successfully compiled Apache 2.0.43 in 64 bits on HP-UX 11.00 (PA-RISC 
2.0W architecture), with dynamic modules.
I had to use libtool and ./buildconf to do it, but it wasn't too hard.

It starts and run, but I've got a problem: in the logfiles, all 
originating IP addresses are 0.0.0.0. They were fine when I compiled it 
in 32 bits (PA-RISC 1.1).

I had a look at the source, it seems that address is a char* called 
remote_ip, part of a struct called connection (which is a struct 
conn_rec), which itself is in another struct request_rec, but I couldn't 
find where it is initialised (too many indirect calls through pointers 
to functions and such, and I haven't done much C those last years).

So, I take it that Apache isn't (yet) completely 64 bit-safe. Does 
anyone has an idea about how to fix my problem ?

TIA,

Laurent

-- 
   IRI-Secodip                  www.infores.com
   4, rue André Derain          mailto:laurent.blume@infores.com
   78240 Chambourcy             tel: +33 (0) 130 06 26 52
   France                       fax: +33 (0) 130 65 09 45


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message