httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zac Stevens <...@cryptocracy.com>
Subject Re: [users@httpd] Runtime failure of httpd v2.0.43 on Solaris 8: fatal: libaprutil-0.so.0: open failed
Date Fri, 17 Jan 2003 16:14:00 GMT
On Fri, Jan 17, 2003 at 11:01:58AM -0500, Joshua Slive wrote:
> On Fri, 17 Jan 2003, Mark Everett wrote:
> > I have been unable to successfully execute apache v2.0.43 under Solaris 8.
> > I have compiled under both GCC v3.2.1 and Sun's professional C compiler
> > (configure options can be seen below).  When I attempt to execute the
> > httpd binary, I receive an error about libaprutil-0.so.0 missing.  This
> > file appears as a symlink to libaprutil-0.so.0.9.2 within the lib dir.
> 
> Getting Sun to find libraries has always been fun for me.  Usually I
> resort to setting the LD_LIBRARY_PATH env variable to include the relevant
> directory.

The simplest way (in this case) is building with

LDFLAGS="-R/path/to/apache/lib"

This forces the Apache libdir into dynamic linkers searchpath.  Also, check
out the following page for some notes about linking on Solaris and why
using LD_LIBRARY_PATH can cause grief down the track

http://www.dcs.warwick.ac.uk/user_guide/faq/ld_lib_path.html


Zac

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message