httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lee Fellows <lfell...@4lane.com>
Subject Re: [users@httpd] referrer is incorrect or not being read by Apache
Date Mon, 13 Jan 2003 20:46:17 GMT
On Mon, 2003-01-13 at 14:55, Eric Wagar wrote:
> I am trying to use a script,  albeit small, to determine where a user
> is coming.
> 
> If the user is coming from the proper address, then the script will
> direct the user to the appropriate page.  If not, then the user will
> be directed to a different page.
> 
> Unfortunately, I am not able to see the appropriate page.  Either I am
> missing something, or forgot to compile something in.  I am using
> Solaris8 with Apache 1.3.27 as the server, and I am using IE6 as my
> browser.
> 
> Any help on why Apache is not seeing the HTTP_REFERRER is very
> appreciated.

  Aside from the fact that relying upon HTTP_REFERRER is problematical,
  1) you mention a script, is this a cgi script?  what language is
     it written in?  Is the configuration correct for passing/reading
     HTTP variables for this script?

  2) How are you testing this?  You make mention of IE6.  How is IE6
     getting the referrer information to pass to your script?  Is it
     passing any referrer information to the script?

-- 
Lee Fellows <lfellows@4lane.com>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message