httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Blair Campbell <blairacampb...@shaw.ca>
Subject Re: [users@httpd] htaccess with 500 error?
Date Mon, 06 Jan 2003 07:57:12 GMT
ok I thought I had that in the htaccess file? so where do I put it?
----- Original Message -----
From: "Jeff Cohen" <apache@gej-it.com>
To: <users@httpd.apache.org>
Sent: Sunday, January 05, 2003 11:35 PM
Subject: RE: [users@httpd] htaccess with 500 error?


You forgot 1 thing:
Require valid-user
And you are done.

Jeff Cohen
> -----Original Message-----
> From: Blair Campbell [mailto:blairacampbell@shaw.ca]
> Sent: Monday, January 06, 2003 2:26 AM
> To: users@httpd.apache.org
> Subject: [users@httpd] htaccess with 500 error?
>
> OK I have spent way to much time password protecting this directory
and
> still no success. Here are the details:
>
> .htaccess in secure directory called /secure
>
> AuthName Secure
> AuthType Basic
> AuthUserFile /usr/local/passwords/herbalifestore4u/.htpasswd
> AuthAuthoritative On
>
>
> <limit GET POST>
> require valid-user
> order allow,deny
> allow from all
> </limit>
>
> httpd.conf directory section
> # Directories...
>
> <Directory "/">
>      Options FollowSymLinks
>
>      AllowOverride All
>
>     Allow from all
>
>
> </Directory>
>
> <Directory "/var/www/html">
>      Options Indexes Includes FollowSymLinks
>
>      AllowOverride AuthConfig
>      Allow from all
>
>
>     Order Deny,Allow
> </Directory>
>
> <Directory "/var/www/icons">
>      Options Indexes MultiViews
>
>      AllowOverride None
>      Allow from all
>
>
>     Order allow,deny
> </Directory>
>
> <Directory "/var/www/cgi-bin">
>      Options ExecCGI
>
>      AllowOverride None
>      Allow from all
>
>
>     Order allow,deny
> </Directory>
>
> permissions are all set to 777 for testing purposes only
>
> Here is my error log:
>
> [Sun Jan  5 01:07:23 2003] [alert] [client 24.64.223.204]
> /var/www/html/herbalifestore4u/secure/.htaccess: Invalid command ' <
Ãõ
> >',
> perhaps mis-spelled or defined by a module not included in the server
> configuration
>
> I have read everything on this possible and still no solutions
>
> THanks
>
> Blair
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server
Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message