httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Subzero" <subz...@spiderweb.tk>
Subject Re: [users@httpd] VirtualDirectory
Date Wed, 29 Jan 2003 23:56:11 GMT
I did this on 1.3.24 so it doesn't work..
i installed 2.0.44 today, hoping it would work, but it didn't..

I can't run the script from the cgi-bin dir itself.. itäs a ikonboard forum
that i am trying to make the VirtualDrectory for.. instead of
www.domain.com/cgi-bin/ikonboard/ i want forum.domain.com..
So, i need to have the ikonboard.pl file in the cgi-bin/ikonboard/ dir..
but the wierd thing is, that when i use www.domain.com/cgi-bin/ikonboard/ it
works perfect and when i use forum.domain.com it doesn't process the file..

What is the best, 1.3.x or 2.0.44 ??
And what is the difference between the two?

I will try and figure out how to make this work, but i doubt i'll get it
right since i'm definately no expert on Apache :)


----- Original Message -----
From: "Jeff Cohen" <apache@gej-it.com>
To: <users@httpd.apache.org>
Sent: Wednesday, January 29, 2003 1:34 PM
Subject: RE: [users@httpd] VirtualDirectory


OK, I've tried all known options on my machine (Win2k Apache 2.0.44) and it
seems that I cannot make the directory to execute the .pl script.
The script will run with the route straight to it, but DirectoryIndex will
not work on the ScriptAlias directory.
I think that in 1.3.x it could be done at the way I mentioned before, can
anyone correct me if I'm wrong please?

My suggestion to you is to try running the script from the cgi-bin directory
itself to try running it from there as a solution, unless somebody in the
list will keep this thread open and help you and me to figure this thing
out.
I guess if nobody will respond to it, it means it's a bug and should be
reported to the development team.

All the best,
Jeff Cohen

> -----Original Message-----
> From: Subzero [mailto:subzero@spiderweb.tk]
> Sent: Wednesday, January 29, 2003 6:26 AM
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] VirtualDirectory
>
> This is the stuff about the VirtualDir that i have in my httpd.conf
>
> NameVirtualHost *
>
> <VirtualHost *>
>     ServerAdmin webmaster@domain.com
>     DocumentRoot "C:/Program Files/Apache Group/Apache/htdocs/"
>     ServerName www.domain.com
>     ErrorLog logs/error_log
>     CustomLog logs/access_log common
> </VirtualHost>
>
> <VirtualHost *>
>     ServerAdmin webmaster@dir.domain.com
>     DocumentRoot "C:/Program Files/Apache Group/Apache/cgi-bin/dir/"
>     ServerName dir.domain.com
>     ErrorLog logs/dir.domain.com-error_log
>     CustomLog logs/dir.domain.com-access_log common
> </VirtualHost>
>
> As i said,
> http://www.domain.com/cgi-bin/dir works
> http://dir.domain.com shows me the correct .pl file, but it doesn't
> process
> it, it types it as a txt file
>
> i have also tried having this
>
>     ScriptAlias /cgi-bin/dir/ "C:/Program Files/Apache
> Group/Apache/cgi-bin/dir/"
>
>     <Directory "C:/Program Files/Apache Group/Apache/cgi-bin/dir">
>         AllowOverride None
>         Options ExecCGI
>         Order allow,deny
>         Allow from all
>     </Directory>
>
> But it doesn't help
> Please someone tell me what i am doing wrong
>
> /Subzero
>
> ----- Original Message -----
> From: "Jeff Cohen" <apache@gej-it.com>
>
> Let's say you want your scripts to be served at
> www.domain1.com/cgi-bin/dir/script.pl, k?
> Then you configure at the conf file like that:
>
> ScriptAlias /cgi-bin/dir/ "/path/to/dir/"
>
> And than you add the <Directory /path/to/dir> directives.
>
> It's that simple.
> All the best,
> Jeff Cohen
>
> > -----Original Message-----
> > From: Subzero [mailto:subzero@spiderweb.tk]
> >
> > Ok, i have done both of them.. one VitrualDirectory and then i got the
> > problem with the .pl file not being processed by apache, so i added a
> > ScriptAlias for that same folder aswell, and i also added that .pl file
> as
> > an index file, so i wouldnät have to type the filename when going to
> that
> > folder..
> > but, i will remove the virtualdirectory and keep the scriptalias.. but
> if
> > i
> > only have the scriptalias, how will i get blabla.blabla.bla working?..
> >
> > /Subzero
> >
> >
> > ----- Original Message -----
> > From: "Jeff Cohen" <apache@gej-it.com>
>
> > Hi Subzero,
> >
> > You should delete the "VirtualDirectory" directive you have set up on
> your
> > conf file and add the directory as "ScriptAlias", check how is the cgi-
> bin
> > directory is configured and copy its directives, than change the route
> to
> > the folder.
> >
> > Hint: the cgi-bin folder have ExecCGI option on its directives.
> >
> > All the best,
> > Jeff Cohen
> >
> > -----Original Message-----
> > From: Subzero [mailto:subzero@spiderweb.tk]
> >
> > Hi
> >
> > I have created a VirtualDirectory in the conf file.
> > The virtualdir is a folder in the cgi-bin, but when i surf to my newly
> > created virtualdirectory, i see the .pl file i am accessing as plain
> > text..
> > Everything works fine as long as i access that file by it's 'real' url,
> > but
> > when i uses the virtual dir, i just see it as plain text, but i do see
> the
> > correct .pl file, so the virtualdirectory setting in httpd.conf is Ok i
> > guess.
> > i have added this folder in the scriptalias setting too.. but it didn't
> > help
> > me.. i guess i really shouldn't need to add it there either, since i
> > already
> > have the cgi-bin there and the folder i have in my vitrualdir is a
> > subfolder
> > of cgi-bin
> >
> > I have read through the FAQ about this and did just as it said, but i
> > still
> > won't get it working..
> > Any ideas on what i am doing wrong or what i have missed?
> >
> > /Subzero
>
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message