httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Cohen" <apa...@gej-it.com>
Subject RE: [users@httpd] VirtualDirectory
Date Wed, 29 Jan 2003 04:00:48 GMT
Let's say you want your scripts to be served at
www.domain1.com/cgi-bin/dir/script.pl, k?
Then you configure at the conf file like that:

ScriptAlias /cgi-bin/dir/ "/path/to/dir/"

And than you add the <Directory /path/to/dir> directives.

It's that simple.
All the best,
Jeff Cohen

> -----Original Message-----
> From: Subzero [mailto:subzero@spiderweb.tk]
> Sent: Tuesday, January 28, 2003 7:02 PM
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] VirtualDirectory
> 
> Ok, i have done both of them.. one VitrualDirectory and then i got the
> problem with the .pl file not being processed by apache, so i added a
> ScriptAlias for that same folder aswell, and i also added that .pl file as
> an index file, so i wouldn├Ąt have to type the filename when going to that
> folder..
> but, i will remove the virtualdirectory and keep the scriptalias.. but if
> i
> only have the scriptalias, how will i get blabla.blabla.bla working?..
> 
> /Subzero
> 
> 
> ----- Original Message -----
> From: "Jeff Cohen" <apache@gej-it.com>
> To: <users@httpd.apache.org>
> Sent: Tuesday, January 28, 2003 9:17 PM
> Subject: RE: [users@httpd] VirtualDirectory
> 
> 
> Hi Subzero,
> 
> You should delete the "VirtualDirectory" directive you have set up on your
> conf file and add the directory as "ScriptAlias", check how is the cgi-bin
> directory is configured and copy its directives, than change the route to
> the folder.
> 
> Hint: the cgi-bin folder have ExecCGI option on its directives.
> 
> All the best,
> Jeff Cohen
> 
> -----Original Message-----
> From: Subzero [mailto:subzero@spiderweb.tk]
> Sent: Tuesday, January 28, 2003 4:13 AM
> To: users@httpd.apache.org
> Subject: [users@httpd] VirtualDirectory
> 
> Hi
> 
> I have created a VirtualDirectory in the conf file.
> The virtualdir is a folder in the cgi-bin, but when i surf to my newly
> created virtualdirectory, i see the .pl file i am accessing as plain
> text..
> Everything works fine as long as i access that file by it's 'real' url,
> but
> when i uses the virtual dir, i just see it as plain text, but i do see the
> correct .pl file, so the virtualdirectory setting in httpd.conf is Ok i
> guess.
> i have added this folder in the scriptalias setting too.. but it didn't
> help
> me.. i guess i really shouldn't need to add it there either, since i
> already
> have the cgi-bin there and the folder i have in my vitrualdir is a
> subfolder
> of cgi-bin
> 
> I have read through the FAQ about this and did just as it said, but i
> still
> won't get it working..
> Any ideas on what i am doing wrong or what i have missed?
> 
> /Subzero
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message