httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gunter Verbocht" <gun...@verbocht.be>
Subject [users@httpd] mod proxy gives strange results
Date Sat, 25 Jan 2003 20:40:01 GMT
Hi,

I used the mod_proxy to forward certain URL's to other servers. Now I
have noticed, that if I have 2 virtual hosts, that it gives a lot off
weird results. I have at the moment this configuration in httpd.conf:

<VirtualHost *>
Servername www.basicdomain.com
Serveralias basicdomain.com
DocumentRoot "/usr/local/www/data"
</VirtualHost>

<VirtualHost domain1.com>
ServerName www.domain1.com
Serveralias domain1.com
DocumentRoot /usr/local/www/domain1_com
ProxyPass / http://other-server.com/domain1/
ProxyPassReverse / http://other-server.com/domain1/
</VirtualHost>

<VirtualHost domain2.com>
ServerName www.domain2.com
Serveralias domain1.com
DocumentRoot /usr/local/www/domain2_com
ProxyPass / http://other-server.com/domain2/
ProxyPassReverse / http://other-server.com/domain2/
</VirtualHost>

When I go to domain1.com, the correct website is loaded
(http://other-server.com/domain1/). But when I go to basicdomain.com or
to domain2.com, I also get the website from domain1.com!!

What is wrong in this configuration?


Regards,

Gunter Verbocht



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message