httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jerry Ford <jf...@katzenjammer.us>
Subject [users@httpd] httpd won't file that is there
Date Wed, 25 Dec 2002 19:48:55 GMT
Hi, just subscribed.  I'm trying to get Apache 1.3.27 and Tomcat 4.1.12
to work together on a Red Hat 7.1 Linux box.

I have a  question about the Apache error log.

When I start Apache, the log shows:

[Wed Dec 25 10:25:24 2002] [error] (2)No such file or directory: Error
while opening the workers, jk will not work

[Wed Dec 25 10:25:24 2002] [error] (2)No such file or directory: Error
while opening the workers, jk will not work

[Wed Dec 25 10:25:24 2002] [notice] Apache/1.3.27 (Unix) mod_jk/1.2.0
configured -- resuming normal operations
[Wed Dec 25 10:25:24 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)

The no file error is listed in the log twice, then Apache appears to
start up, but---as advertised---jk doesn't work.But the workers file is
present and the pointer to it in httpd.conf is correct:

JkWorkersFile
"/usr/local/webserver/jakarta-tomcat-4.1.12-LE-jdk14/conf/jk/workers.properties"

Apache and Tomcat both appear to run fine on their own:

http://localhost opens the Apache index
http://localhost:8080 opens the Tomcat index and servlets and jsps work
http://localhost/<path to servlet's html page> works fine
http://localhost/<path to servlet> does not work; Apache port 80
Internal Server error

According to the Tomcat log, mod_jk appears to be running:

Dec 24, 2002 4:44:48 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on port 8080
Starting service Tomcat-Standalone
Apache Tomcat/4.1.12-LE-jdk14
Dec 24, 2002 4:44:55 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on port 8080
Dec 24, 2002 4:44:55 PM org.apache.jk.common.ChannelSocket init
INFO: JK2: ajp13 listening on tcp port 8009
Dec 24, 2002 4:44:55 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=1/133
config=/usr/local/webserver/jakarta-tomcat-4.1.12-LE-jdk14/conf/jk2.properties

Can somebody tell me the conditions under which the "No such file or
directory" error could be generated in Apache when the file does exist
and the path to it are correctly entered?

Is it a permissions thing (the file has -rw-rw-r permissions, and all
directories in the chain have drwxr-xr-x; my Apache directories belong
to root:root, but I've also tried changing ownership to jford:jford with
the same results; also have tried changing file permissions to
-rwxrwxrwx).

I know the path specified in httpd.conf is correct; I can copy it and do
an ls.

There are no symbolic links in the path reference in httpd.conf (though
I have tried it with  the tomcat directory a symbolic link).

Thanks.

Jerry



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message