httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laurent Blume <laurent.bl...@infores.com>
Subject Re: [users@httpd] Compiling Apache 2.0.43 on HP-UX 11.00
Date Thu, 19 Dec 2002 16:22:47 GMT
Andy Cutright wrote:
> i'm using all HP compile tools to run this build. we've built httpd 
> *.35, *.39, and now *.43. are you sure you don't have some mix of tools 
> on your path, e.g., some gnu, some hp?

I thought about that, and as far as I can tell, no.
There *should* not be any GNU tool installed. cc is /usr/bin/cc 
symlinked to /opt/ansic/bin/cc, ld is /usr/bin/ld to /usr/ccs/bin/ld.

> here's our configure line:
> 
> SHARED_MODS=--enable-cache=shared --enable-cern_meta=shared 
> --enable-charset_lite=shared --enable-dav=shared --enable-example=shared 
> --enable-ext_filter=shared --enable-file_cache=shared 
> --enable-mime_magic=shared --enable-proxy=shared --enable-suexec=shared 
> --enable-unique_id=shared --enable-usertrack=shared
> 
> ./configure --prefix /vobs/WEB/src/apache2/apache_deploy_root 
> --enable-module=most --enable-mods-shared=most --with-port=7080 
> --with-mpm=worker  --enable-ssl --with-ssl=$(SSL_INST) $(SHARED_MODS)

I'm going to try that, thought it doesn't look much different...

> also, i've got a build problem on AIX to do with shlibtool. you might 
> take a look at the release notes & see if there's any mention of 
> requiring a custom built libtool for hp (though we're not facing this).

Yes, it's definitely shlibtool that fails. I checked the compilation 
output, all the libtool calls (static linking) succeed, while the first 
shlibtool call (shared) fails.
If I modify this shlibtool for static, it passes.
I got libtool 1.4.3 from gnu.org, checked there have been some HP-UX 
shared libraries bugs corrected since version 1.4, compiled it, and put 
it first in the PATH, but it seems the apr configure script forces the 
use of its own included libtool 1.3.4.

I'm going to give it a bit more try, but if I can't find a reasonably 
easy way to do it, I stay with static linking.

Thanks for your help,

Laurent

> 
> cheers,
> andy

-- 
   IRI-Secodip                  www.infores.com
   4, rue André Derain          mailto:laurent.blume@infores.com
   78240 Chambourcy             tel: +33 (0) 130 06 26 52
   France                       fax: +33 (0) 130 65 09 45


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message