httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eric lin <fs...@centurytel.net>
Subject [users@httpd] Re: newbie's apache , internal server error, please help
Date Fri, 13 Dec 2002 05:18:51 GMT
[Thu Dec 12 19:55:46 2002] [error] (2)No such file or directory: exec of 
/usr/lib/cgi-bin/entrance.pl failed
[Thu Dec 12 19:55:46 2002] [error] [client 64.91.61.186] Premature end 
of script headers: /usr/lib/cgi-bin/entrance.pl[Thu Dec 12 19:56:11 
2002] [notice] caught SIGTERM, shutting down
[Thu Dec 12 19:57:45 2002] [notice] Apache/1.3.26 (Unix) Debian 
GNU/Linux configured -- resuming normal operations
[Thu Dec 12 19:57:45 2002] [notice] suEXEC mechanism enabled (wrapper: 
/usr/lib/apache/suexec)
[Thu Dec 12 19:57:45 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Dec 12 19:59:37 2002] [error] (2)No such file or directory: exec of 
/usr/lib/cgi-bin/entrance.pl failed
[Thu Dec 12 19:59:37 2002] [error] [client 64.91.61.186] Premature end 
of script headers: /usr/lib/cgi-bin/entrance.pl[Thu Dec 12 20:13:08 
2002] [error] (2)No such file or directory: exec of 
/usr/lib/cgi-bin/entrance.pl failed
[Thu Dec 12 20:13:08 2002] [error] [client 6

this is my /var/log/apache/error.log


www:/home/fsshl# #!/usr/local/bin/perl
bash: !/usr/local/bin/perl: event not found

I tried  first line of the command, but it immediately failed

hope to see your help again



Rodent of Unusual Size wrote:
> eric lin wrote:
> 
>>i tried to put a simple perl file in my /usr/lib/cgi-bin/entrance.pl
>>
>>#!/usr/local/bin/perl
>>use strict;
>>use CGI ':standrard';
>>
>>print "Content-type: text/html\n\n";
>>
>>foreach my $name (param()) {
>>   my @cpu=param($name);
>>   print "<p>The field with the NAME attribute euual to <b>
>>         $name</b> had a VALUE equal to <b>@cpu</b></p>\n";
> 
> 	:
> 
>>when I click the submit bottom of my site in my browser it still
>>Internal Server Error
> 
> 
> the first thing to check in a case like this is the apache error
> log (probably logs/error_log under the apache serverroot).  next
> is to try to run the script from the command line, though that's
> somewhat difficult with the cgi module.  try these and see what
> messages you get; they'll be key to figuring out what to do next.


-- 
Sincere Eric
www.linuxspice.com
linux pc for sale


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message