httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Walls <k6...@earthlink.net>
Subject Re: [users@httpd] Alias not working
Date Tue, 03 Dec 2002 13:45:20 GMT
I response to my question about having problems getting Alias to work on a Win
2K based Apache web server, there were 2 responses overnight:

Boyle Owen wrote:

> So what you're saying is that:
>
>         > Alias /manual "C:/Program Files/Apache Group/Apache2/manual"
>
> works, but:
>
>         > Alias /news "D:/Shared/APRS/ArchiveData/News"
>
> doesn't and that your error is:
>
>         > "The requested operation has failed!"
>
> Am I right?

Correct. The failure of Apache to start and the above error only happens when
I do not have the <Directory... statement that follows the Alias statement
REMed out.  But as I understand it, the Alias statement should work without
the <Directory... statement - it did when I used the following as a test:
Alias /man "C:/Program Files/Apache Group/Apache2/manual"
That correctly pointed to the manual directory.

> If so, since the error is not a typical apache error but rather sounds
> like it is coming from the OS, I would guess that the apache process is
> failing to mount the D: drive. I'm no windows expert, but I believe
> Win2K now has the concept of users and permissions. So apache presumably
> runs as a particular user (e.g. "apache") and this guy has to be allowed
> to access D:
>
> Check out the users permissions scheme (no idea how it works in win2K -
> maybe some windows guys know?)

Yes, Win 2K understands file permissions just fine.  I believed I had thast
right, but as a test I gave everyone read access to that directory and it did
not help.


Also, Sander Holthaus wrote:

> Alias /news "D:/Shared/APRS/ArchiveData/News" does not point to a
> directory, but a file. Hence the 404, it cannot find the file /news. If you
put
> a traling / behind those, Apache will now that your aliasing a directory.

> So you should use
> Alias /news/ "D:/Shared/APRS/ArchiveData/News/"

> At least, that would be the case on *nix.

Nope.  D:/Shared/APRS/ArchiveData/News is a directory.  I have tried it both
with and without the trailing slash.  I have also tried a URL that includes a
specific filename in /news (i.e. http://mywebsite.org/news/filename), and
still get the 404 error.

-----------------------
Jim Walls - K6CCC
k6ccc@amsat.org
http://home.earthlink.net/~k6ccc/
626-302-8515    FAX  626-302-7501
AMSAT member 32537 / WSWSS member 395
To send me PGP encrypted E-Mail, use:
http://home.earthlink.net/~k6ccc/PublicKey.html



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message