httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Murphy <ianpmur...@yahoo.fr>
Subject [users@httpd] Config problem with apache 1.2, php and SSI
Date Mon, 30 Dec 2002 15:22:12 GMT
I've been setting up Apache 1.3 with php 4 on an w2k machine and
everything worked well the first time until I wanted to use some php
scripts sitting on another drive, which resulted in an 'internal server
error'. I have traced my way backwards and have found that it seems to
come down to a config problem with the <directory> directive. 

I created a script
  d:/program files/apache group/apache/htdocs/mail/test.php, 

with phpinfo() in it. I also created an alias to the same directory and
added a directive

  Alias /test "D:/Program Files/Apache Group/Apache/htdocs/mail"
  <Directory "D:/Program Files/Apache Group/Apache/htdocs/mail">
      Options Indexes FollowSymLinks MultiViews Includes
      AllowOverride None
      Order allow,deny
      Allow from all
  </Directory>

it works fine using the url
  http://myserver/mail/test.php

but fails with internal server error when I use 
  http://myserver/test/test.php

the only difference being the fact that its aliased. The 'Options
includes' should tell apache to allow ssi's, no?

What have I missed?

Regards

Ian Murphy


___________________________________________________
Yahoo! Postales
Felicita las Navidades con las postales más
divertidas desde http://postales.yahoo.es

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message