httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Turner <kk...@sbcglobal.net>
Subject Re: [users@httpd] semget: No space left on device
Date Wed, 27 Nov 2002 05:48:29 GMT
On Tue, 26 Nov 2002 17:02:45 -0000, Uwe Kolsch wrote:

>Hi,
>
>I run Apache 1.3.27 on RedHat 8 in combination with Tomcat. Because of some
>configuration changes in httpd.conf (just a new vhost) I had to restart
>httpd. It stopped and did not came up again. The only error output I found
>was "semget: No space left on device" in the Apache error_log. As it was a
>production server I decided to reboot the machine and it came up fine.
>However, I'm puzzled about the cause of this error. The server is quite a
>high end machine and there is certainly not a shortage of resources. It was
>running fine before the restart for weeks and did not show any problems
>right before the event, and it runs since fine since it came up again.

This is *not* the authoritative answer :)

Two possibilities come to mind:
    On restart, httpd may have tried to start too many
[child?]processes.  Often another restart will cure the problem (no idea
why, but a google supports this plan);
    Or, logrotate may have gone crazy and created umpty-zillion *.*.*.gz
files.  This will eat up your inodes.  In my case, IIRC, 64K files were
created in /var/log/.  (This is a strong argument for a separate /var
partition.)  Fortunately, deleting the files restored sanity.  It hasn't
happened again and I have let well enough alone.  I have no clue why it
happened.

--
gt       kk5st@sbcglobal.net
It ain't so much what you don't know that gets you in trouble---
it's what you do know that ain't so.--unk

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message