httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Szey...@aol.com
Subject [users@httpd] cgi_script is downloaded, not displayed in browser
Date Sat, 09 Nov 2002 11:41:46 GMT
Hi, 
I am new to Apache. I installed Apache in order to view the output of cgi 
scripts.I need it for the home assignments for the class I am taking now.I 
put my perl (*.pl) scripts in the cgi-bin:C:\*\*\Apache2\cgi-bin.
If I put in my browser the address http://localhost, I see apache's 
index.html page OK. However, I cannot execute my cgi scripts.If I run a 
script "printenv.pl" from this page, I am getting file download dialog - 
instead of viewing the output of the script:"You are downloading the file 
"printenv.pl from localhost. Would you like to open file or save it to your 
computer?"
When I try to execute my html file from some unrelated to apache directory, I 
get when I will the form and click on submit:Address: 
C:\cgi-bin\hiddenFields.pl
"The page cannot be displayed". The address tells that alias to cgi script 
does not work. Why?
What am I missing?
The second question is: I run Apache as a service. Can I reconfigure it to 
run from console without deinstallation->installation?

Thanks a lot. Below is my configuration

Sophia Zeyger
=============================================

My OS is Windows XP. My browser is IE 6.0.2600.0000 .My httpd.conf has the 
following lines ( some of them I edited based on the discussion I viewed in 
this usergroup mail).
=================================================
ServerRoot "C:/Program Files/Apache Group/Apache2"
Listen 127.0.0.1:80
ServerAdmin szeyger@aol.com 
ServerName localhost
UseCanonicalName Off
DocumentRoot "C:/Program Files/Apache Group/Apache2/htdocs"
...
<Directory "C:/Program Files/Apache Group/Apache2/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all

</Directory>
UserDir "C:/Documents and Settings/Owner/My Documents/My Website"
DirectoryIndex index.html index.html.var
AccessFileName .htaccess
ScriptAlias /cgi-bin/ "C:/Program Files/Apache Group/Apache2/cgi-bin/"
# SZ Trying to make cgi scripts work. Adding from usergroup mail:
<Directory "c:/program files/apache group/apache2/htdocs">
  Options +ExecCGI
</Directory>
# SZ: Adding handler for perl scripts
    AddType application/x-httpd-cgi .pl
    AddHandler cgi-script .pl
<Location /server-status>
    SetHandler server-status
    Order deny,allow
    Deny from all 
    Allow from HEWLETT-GRAP4UX
</Location>
<Location /server-info>
    SetHandler server-info
    Order deny,allow
    Deny from all
    Allow from HEWLETT-GRAP4UX
</Location>


Mime
View raw message