httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject [users@httpd] Re: Start/Stop Apache
Date Fri, 15 Nov 2002 03:54:57 GMT

On Thu, 14 Nov 2002, Thomas Kernes wrote:

> /etc/httpd/bin/httpd -k start is command in the apachectl
>
> Apache version is 2.0.43 compiled for YDL 2.1 on PPC
>
> When I run the command above (as root) I get the same thing:
[...]
> I guess I just don't know why the one process is owned by root AND why it
> won't die.
>
> I do appreciate your input though.  I will take whatever advice you have to
> give.

It is completely normal for one process to be owned by root.
See: http://httpd.apache.org/docs-2.0/invoking.html
or the documentation of your MPM.

Now your problem is how to get Apache to stop.

Step 1: signal the root-owned process:
kill `cat /usr/local/apache2/logs/httpd.pid`
(You should probably check and make sure the httpd.pid does indeed contain
the pid of the root-owned apache process.)

Assuming that step 1 worked, start apache again and try this:
httpd -k stop

Assuming that works, start it again and try
apache stop

Let us know which step is failing.

Joshua.



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message