httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] Apache 2 High Weirdness
Date Tue, 19 Nov 2002 00:39:15 GMT

On Mon, 18 Nov 2002, D Uhlman wrote:
> The environment is a updated, modified and hardened redhat 7.1/7.3 and
> the apache 2 packages I have tried are internal (50km version 2.0.43)
> and the redhat 8 2.0.40 compiled for the 7.3 environment. Both work fine
> in a test environment under kernel 2.4.2-2 or 2.4.9. The servers are
> running a virtuozzo provided 2.4.9 (I have no easy control over this) so
> really the only difference is in the kernel from test to production
> systems. Here is where things get strange.
>
> Apache installs and works fine through https (mod_ssl 2.0.40 or 2.0.43)
> or using php (4.2.3) to generate pages. However when it comes to serving
> regular static pages over http it fails. The nature of this failure is such:
>
> cannot serve a static page over 255 bytes

And does it work find outside this virtuozzo thing?

You might try turning off mmap and sendfile to see if your virtual
environment has problems with one of those.  mmap can be turned off using
the EnableMMap directive.  Sendfile can be turned off using the
EnableSendfile directive, but that is only available in the cvs
development version of apache.  With older versions, you'll need to
recompile with (I think) --disable-sendfile.

Joshua.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message