httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Saqib.N....@seagate.com
Subject RE: [users@httpd] Apache2.0.43 w/ ldap on Solaris
Date Fri, 22 Nov 2002 23:21:03 GMT

For 42 I think, the source code for the LDAP authentication is not in the
core, and has to be downloaded separately from the Apache Server CVS.

Place the downloaded sourcecode in the  $APACHE_SOURCE/modules directory.
Next run buildconf. The following configure command can be used to enable
LDAP authentication support

--enable-ldap --with-ldap --with-auth-ldap --enable-auth-ldap

Running buildconf is the important step.

In Peace,
Saqib Ali
http://docbook.sc-icc.org


                                                                                         
                                       
                    "Hulslander,                                                         
                                       
                    Ryan"                 To:     "'users@httpd.apache.org'" <users@httpd.apache.org>
                           
                    <Ryan.Hulsland        cc:                                         
                                          
                    er@ps.net>            Subject:     RE: [users@httpd] Apache2.0.43 w/
ldap on Solaris                         
                    No Phone Info                                                        
                                       
                    Available                                                            
                                       
                                                                                         
                                       
                    11/22/2002                                                           
                                       
                    03:13 PM                                                             
                                       
                    Please respond                                                       
                                       
                    to users                                                             
                                       
                                                                                         
                                       
                                                                                         
                                       




> -----Original Message-----
> From: Saqib.N.Ali@seagate.com [mailto:Saqib.N.Ali@seagate.com]

>
> Works just fine on Linux .....
> In Peace,
> Saqib Ali

I'd really like to know how you got it to work! I posted a question on how
to just get the module COMPILED with Apache on Linux and nothing - nary a
peep. Is .43 the only one that LDAP works with? Here's the message I
posted:

Background;
I'm running Apache 2.0.42 under SuSE linux 8.0 and building Apache from the
source

Problem;

I need to install an LDAP module to handle authentication, and everything I
try on the configure script that I see in the documentation doesn't seem to
want to work. I tried the following:

./configure --enable-ssl --enable-file-cache --enable-deflate
--enable-mpm=worker --with-ldap

and I got

checking for ldap support...
checking for ldap_init in -lldap50... no
checking for ldap_init in -lldapssl41... no
checking for ldap_init in -lldapssl40... no
checking for ldap_init in -lldapssl30... no
checking for ldap_init in -lldapssl20... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... (cached) no
checking for ldap_init in -lldap... (cached) no
configure: error: could not find an LDAP library
configure failed for srclib/apr-util

I also tried

./configure --enable-ssl --enable-file-cache --enable-deflate
--enable-mpm=worker --enable-ldap

The configure seems to work, but when I proceed with the make step, I get

util_ldap.c:81: #error mod_ldap requires APR-util to have LDAP support
built
in

Does anyone have any ideas? Everything works and compiles great except for
when I add in the ldap info.

Any help would be DEEPLY appreciated!

Thanks!

Ryan Hulslander
ryan.hulslander@ps.net


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org





---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message