httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hulslander, Ryan" <Ryan.Hulslan...@ps.net>
Subject [users@httpd] LDAP Authentication for 2.0 - can't configure/build
Date Fri, 15 Nov 2002 20:32:33 GMT
Background;
I'm running Apache 2.0.42 under SuSE linux 8.0 and building Apache from the
source

Problem;

I need to install an LDAP module to handle authentication, and everything I
try on the configure script that I see in the documentation doesn't seem to
want to work. I tried the following:

./configure --enable-ssl --enable-file-cache --enable-deflate
--enable-mpm=worker --with-ldap

and I got

checking for ldap support...
checking for ldap_init in -lldap50... no
checking for ldap_init in -lldapssl41... no
checking for ldap_init in -lldapssl40... no
checking for ldap_init in -lldapssl30... no
checking for ldap_init in -lldapssl20... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... (cached) no
checking for ldap_init in -lldap... (cached) no
configure: error: could not find an LDAP library
configure failed for srclib/apr-util

I also tried 

./configure --enable-ssl --enable-file-cache --enable-deflate
--enable-mpm=worker --enable-ldap

The configure seems to work, but when I proceed with the make step, I get 

util_ldap.c:81: #error mod_ldap requires APR-util to have LDAP support built
in

Does anyone have any ideas? Everything works and compiles great except for
when I add in the ldap info.

Any help would be DEEPLY appreciated!

Thanks!

Ryan Hulslander
ryan.hulslander@ps.net



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message