httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Segree, Gareth" <Gareth.Seg...@gleanerjm.com>
Subject RE: [users@httpd] 2.0.40 compilation
Date Mon, 18 Nov 2002 17:22:25 GMT
Make sure openssl & openssl-devel is installed

-----Original Message-----
From: Joxn [mailto:joxn@vernum.com]
Sent: Saturday, September 14, 2002 12:57 PM
To: users@httpd.apache.org
Subject: [users@httpd] 2.0.40 compilation


Hi everybody,
first of all, I am new to this list and I am not sure if this is the 
correct list.

Here's what I get when I try to compile Apache 2.0.40:

make[3]: Changing to »/usr/src/packages/install/httpd-2.0.40/modules/ssl«
Building shared: mod_ssl.la
make[4]: Changing to »/usr/src/packages/install/httpd-2.0.40/modules/ssl«
/bin/sh /usr/src/packages/install/httpd-2.0.40/srclib/apr/libtool
--silent --mode=compile gcc  -g -O2 -pthread -DNO_DBM_REWRITEMAP
-DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE
-D_GNU_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER
-I/usr/src/packages/install/httpd-2.0.40/srclib/apr/include
-I/usr/src/packages/install/httpd-2.0.40/srclib/apr-util/include -I.
-I/usr/src/packages/install/httpd-2.0.40/os/unix
-I/usr/src/packages/install/httpd-2.0.40/server/mpm/prefork
-I/usr/src/packages/install/httpd-2.0.40/modules/http
-I/usr/src/packages/install/httpd-2.0.40/modules/filters
-I/usr/src/packages/install/httpd-2.0.40/modules/proxy
-I/usr/src/packages/install/httpd-2.0.40/include -I/usr/include/openssl
-I/usr/src/packages/install/httpd-2.0.40/modules/dav/main -prefer-pic -c
mod_ssl.c && touch mod_ssl.slo
In file included from mod_ssl.h:140,
                   from mod_ssl.c:60:
/usr/include/unistd.h:946: parse error before '(' token
/usr/include/unistd.h:946: parse error before "const"
make[4]: *** [mod_ssl.slo] Error 1
make[4]: Leaving Directory
»/usr/src/packages/install/httpd-2.0.40/modules/ssl«
make[3]: *** [shared-build-recursive] Error 1
make[3]: Leaving Directory
»/usr/src/packages/install/httpd-2.0.40/modules/ssl«
make[2]: *** [shared-build-recursive] Error 1
make[2]: Leaving Directory »/usr/src/packages/install/httpd-2.0.40/modules«
make[1]: *** [shared-build-recursive] Error 1
make[1]: Leaving Directory »/usr/src/packages/install/httpd-2.0.40«
make: *** [all-recursive] Error 1

I compile Apache with
--with-ssl=/usr/include/openssl --enable-ssl
--enable-rewrite=shared --enable-usertrack --enable-speling=shared
--enable-info --enable-mods-shared=all --enable-so --enable-ldap
--enable-dav
and a custom config.layout

I am using gcc-3.2 on a Linux-from-Scratch system.

If anybody has any suggestions, I'd be glad to hear them.

TIA.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message