httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adolf, Michael F" <michael.f.ad...@lmco.com>
Subject [users@httpd] Apache Tomcat Realm Problem
Date Tue, 26 Nov 2002 16:20:05 GMT
Running Tomcat via Forte 4.0 up1.  My application, sedb, has the following
security constraint in its web.xml

  <security-constraint>
    <web-resource-collection>
      <web-resource-name>sedb</web-resource-name>
      <description>SEDB web site</description>
      <url-pattern>/*</url-pattern>
    </web-resource-collection>
    <auth-constraint>
      <description>SCISW Client Server Group</description>
      <role-name>clientserver</role-name>
    </auth-constraint>
  </security-constraint>
  <login-config>
    <auth-method>BASIC</auth-method>
    <realm-name>sedb</realm-name>
  </login-config>
  <security-role>
    <description>SCISW Client Server Group</description>
    <role-name>clientserver</role-name>
  </security-role>

When I execute application within Forte I get the error:

"No Realm has been configured to authenticate against."

and the browser claims /index.html is not available.

If I remove only the <security-constraint> container, it work OK.

I can't see anything wrong with the above and server.xml contains the
default <realm> for Memory realm.  What am I missing?

Please Help!
Mike

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message