httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Douglas King <dak...@dak1.net>
Subject [users@httpd] Problems with Apache 1.3.23
Date Wed, 27 Nov 2002 08:55:59 GMT


>I have begun having a problem with my Apache server. The problem is as
>follows:
>
>I am not able to run / execute ANY Perl or cgi scripts...at all.
>
>In the error log for Apache, I get the following error message:
>
>[Tue Nov 26 21:47:33 2002] [warn] (24)Too many open files: unable to open a
>file descriptor above 15, you may need to increase the number of descriptors
>
>[Tue Nov 26 21:47:34 2002] [notice] Apache/1.3.23 (Unix) (Red-Hat/Linux)
>mod_ssl/2.8.7 OpenSSL/0.9.6b DAV/1.0.3 PHP/4.1.2 mod_perl/1.26 configured
>-- resuming normal operations
>
>[Tue Nov 26 21:47:34 2002] [notice] suEXEC mechanism enabled (wrapper:
>/usr/sbin/suexec)
>
>[Tue Nov 26 21:47:34 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)
>
>[Tue Nov 26 21:47:52 2002] [error] [client 66.14.30.174] (24)Too many open
>files: couldn't spawn child process: 
>/var/www/cgi-bin/domainname/mycgi_list.cgi
>
>
>Here is the info on the server:
>
>It's an Athalon 650 mhz processor
>
>768 meg ram
>
>It's a Red Hat 7.3 machine running Apache 1.3.23 for the web server.
>
>The cgi scripts used to run...but has recently stopped. The kernel, 2.4.19
>was recently re-configured to basically have unlimited resources
>available...and the file limit or process was set to something like 1024.
>
>Has anybody run across this problem? If so....what is my solution?


Mime
View raw message