httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyle Owen" <Owen.Bo...@swx.com>
Subject RE: [users@httpd] Apache SSL - using port 80 & 443 for same IP address & Server Name
Date Fri, 08 Nov 2002 10:00:22 GMT
Your configuration is exactly correct and I don't think the problem lies
with apache. "server could not be found" could be many things (what
browser is this?):

- that the browser could not resolve the server name to an IP address
(hence DNS problems). If this, use nslookup to test the DNS.

- that the server did not respond to the request (is apache really
running? is it really listening on port 80 and 443?) If this, check the
IP address of your server matches that in DNS (ifconfig -a to check
that) and then check you are listening on the ports (netstat -a | grep
80, netstat -a | grep 443).

What does it say in the common error log when you try to start apache?
Do you get the "could not be found" on both HTTP and HTTPS?

Rgds,

owen Boyle


 
>-----Original Message-----
>From: Emma Grant [mailto:egrant@busydata.com]
>Sent: Freitag, 8. November 2002 10:11
>To: httpd
>Subject: [users@httpd] Apache SSL - using port 80 & 443 for same IP
>address & Server Name
>
>
>Hi,
>
>I have been reading through the emails (subscribers)  and 
>thought that I had
>this problem figured out. If someone can help me out that 
>would be great, if
>someone tells me to RTFM, and shows me where the FM is that 
>would be great
>too. :)
>
>So...
>
>I have Apache set up with Named Virtual Host (For Non-SSL). I 
>then have IP
>Based Virtual Hosts (For SSL).
>
>Well I want to have : http://www.mysite.com and 
>https://www.mysite.com So I
>set up a Virtual Host Tag for the non ssl like so...
>
>Listen 123.123.123.123:80
><VirtualHost 123.123.123.123:80>
>ServerName www.mysite.com
>....
></VirtualHost>
>
>I then have the SSL like so:
>
>Listen 123.123.123.123:443
><VirtualHost 123.123.123.123:443>
>ServerName www.mysite.com
>CertificateFile /mypath/mycert.crt
>....
></VirtualHost>
>
>Now since I have 1) a seperate IP address for ssl, away from 
>the Name Based
>Hosts, and 2) I have the IP address using two different ports for the
>different IP Based VH, I thought that this would work. But instead I am
>timing out can getting a "server could not be found error".
>
>Any ideas?
>
>Thanks,
>
>EMG
>
>
>
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP 
>Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>
>

This message is for the named person's use only. It may contain
confidential, proprietary or legally privileged information. No
confidentiality or privilege is waived or lost by any mistransmission.
If you receive this message in error, please notify the sender urgently
and then immediately delete the message and any copies of it from your
system. Please also immediately destroy any hardcopies of the message.
You must not, directly or indirectly, use, disclose, distribute, print,
or copy any part of this message if you are not the intended recipient.
The sender's company reserves the right to monitor all e-mail
communications through their networks. Any views expressed in this
message are those of the individual sender, except where the message
states otherwise and the sender is authorised to state them to be the
views of the sender's company. 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message